Group Membership in User Objects not displayed

Hello,

we´ve switched our authentication ressource from one LDAP to another LDAP - System. The usernames are the same in both systems.

We´ve exported the group memberships of the users via CLI to a CSV file to save them, switched the LDAP Ressource, synchronized and imported the CSV again.

The Group Memberships seemed to be imported so far, because we can see users in the groups.

But when we have a look at a user object, there are no group memberships displayed.

 

When a User logs in, the user has the correct access, but in the administration section there is no association to any group displayed.

 

How can we fix that?

1 answer

0 votes

Hi Jim,

This is not a problem that I'm expert with, however my bet is that there is inconsistency in the database group memberships or indexes of the instance.

If you have an old copy of the database, I recommend to restore it to another database and compare the membership table.

On a sidenote, if both LDAPs are the same, by creating a new user directory in Confluence pointing to the new LDAP, it should sync the users, groups and memberships located in the LDAP directory.

I hope this help.

Cheers,

Rodrigo

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,009 views 14 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you