Global spaces are not shown on dashboard after Upgrade from Confluence 3.5.16 to 4.3.1

3 answers

Hi there,

Could you please elaborate on more detail in regard to no global space shown detailed. By default, Confluence 4 will only display 20 spaces in the dashboard, while the other are accessible trough Space Directory.

If there are no spaces listed at all, you might want to check if there are any customization done on your dashboard and revert it back to default (backup it first) for troubleshooting purposes.

UPDATE:

Thanks for the screenshot. Looks like it is an indexing issue. For troubleshooting purposes you might want to try to disable all attachment indexing, reindex from scratch again and see if the issue persist.

Hope it helps.

Cheers,
Septa Cahyadiputra

Hi Septa..

Thanks for the note. I have attached a snapshot of the dashboard. There are about 70 global spaces and non of them is displayed at all. Below are the steps are carried out before I run into this issue:

  • Created a duplicate copy(test instance) of production Confluence 3.5 and this worked well with not glitch..all spaces were visible
  • I then upgraded the test instance to 4.3.1 and again it completed successfully BUT the global spaces are not showing.

I also tried re-indexing and it did not help at all. Also there is not customizaton on the dashboard.

Thanks for the screenshot. Looks like it is an indexing issue. For troubleshooting purposes you might want to try to disable all attachment indexing, reindex from scratch again and see if the issue persist.

I tried this a couple of hours ago and it did not work.

Is Confluence integrated with LDAP?

It is integrated with AD and not ldap.

Managed to fix this. 4.3.x has a new field called spacestatus in the spaces table. During the upgrade process, a null value is placed in there for each space and thats why the spaces dont display on the dashboard. If u manually update this to current for each space., this issue gets fixed.

I am experiencing the same problem; this did not occur moving from 3.5.2 -> 4.3, but it does when moving to 4.3.6. Is this issue fixed in a newer version?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

778 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you