Gliffy Permission Error after Upgrade to 6.9.0

Our instance is currently 5.7.1 and our Gliffy plugin is 6.9.0.  We upgrade this plugin and are now receiving the following error when attempting to edit or create a new diagram:

Sorry, you cannot create new diagrams but you may insert existing ones.
No create permission or you are not logged in.

In the js console, I see the following 404 errors when trying to edit and insert a diagram:

https://domain.com/rest/gliffy/1.0/ceo/48399048/permission?_=1462278616866
 
https://domain.com/rest/gliffy/1.0/properties/com.gliffy.integration.confluence.ANALYTICS_OFF?_=1462278621212
 
https://domain.com/rest/gliffy/1.0/diagrams.json?query=&index=0&results=20&spaceKey=&sort=modified&order=descending&_=1462278621219


https://domain.com/rest/gliffy/1.0/spaces/legacy.json?_=1462278621214

I've attempted to reinstall the plugin at version 6.9.0, clear plugin cache, use a developer license, and I've tried 3 different browsers.  

Catching a lot of stack trace / dumps like the following:

Location:

    com/gliffy/plugin/confluence/api/v1/DiagramResource.saveAs(Ljava/lang/String;JLjava/lang/String;Ljava/lang/Integer;Ljava/lang/Long;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;Z)Ljavax/ws/rs/core/Response; @450: invokevirtual

  Reason:

    Type 'java/lang/Object' (current frame, stack[1]) is not assignable to 'com/atlassian/confluence/core/SpaceContentEntityObject'

  Current Frame:

    bci: @450

    flags: { }

    locals: { 'com/gliffy/plugin/confluence/api/v1/DiagramResource', 'java/lang/String', long, long_2nd, 'java/lang/String', 'java/lang/Integer', 'java/lang/Long', 'java/lang/String', 'java/lang/String', 'java/lang/String', integer, 'com/newrelic/agent/bridge/Transaction', 'com/newrelic/agent/bridge/ExitTracer', 'com/atlassian/confluence/core/ContentEntityObject', 'com/atlassian/confluence/pages/Attachment', 'com/atlassian/confluence/pages/Attachment', 'java/lang/String', 'java/lang/Object' }

    stack: { 'java/lang/StringBuilder', 'java/lang/Object' }

1 answer

This widget could not be displayed.

Hi Robert,

We've received your support request and are investigating the problem. Right now it looks to be caused by some sort of conflict with NewRelic. If possible, could you please temporarily disable the NewRelic agent to help us verify this?

As a workaround, you can downgrade to Gliffy 6.8.8 if that version worked well for you. In the meantime, we will continue investigating and will reach out to you with updates over the Gliffy support channel. I will also update this ticket once we have a final resolution (in case anyone else comes across the problem).

Regards,
Mike Cialowicz
Gliffy, Inc.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

157 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you