Getting 404 error when pasting text into page

We're running 5.1.2 and when trying to paste text into the Edit page I get a 404 Error - The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

This is even with straight plain text, no special characters at all - not even a period.

Thanks,

Jon

6 answers

1 accepted

2 votes
David Simpson Community Champion May 21, 2013

In Confluence Admin | Manage Add-ons type: "Paste" and select "Add Add-Ons" from the dropdown.

You have a problem with the "Confluence Paste" plugin and need to ensure that all modules are enabled.

If all is good, it should look like this:

http://i.minus.com/jOpOSB8AcisqC.png

Re-enable all the modules. Fingers crossed.

13 of 13 are enabled.

Found the problem. Looking at the Modules for Confluence Paste reminded me of a change I had to make to test an internal product. In IE there is scripting permission that allows acces to the Clipboard and I had to disable that last week and had forgotten all about it.

Changed that back to allow on our Intranet and it pasting then worked again.

Thank you for your quick responses and I am going to make a note for our other users in case they hit this as well.

Going to mark David's as the key Answer.

Thanks,

Jon

Some initial questions:

  • What is the context of the text? URLs?
  • Why are you copying text, if I may ask.
  • Are you migrating a bunch of content, manually?
  • Do you have plugins installed, and which ones?
  • Was everything running smooth before you copied the content?
  • You said Edit page, so this is not when creating a new page?
  • What does the URL say when you get the 404 error? Any clues?

I would check the logs in your Confluence server and see if you see anything that gives you a clue - or create a ZIP package and open a ticket with support@atlassian.com

Kinda need more info on what is going on here to help more -

Answers to your questions:

1 - As I said above it happens with plain text.

2 - Because I need to. Regardless of why I'm pasting text into the editor it should allow me to paste text into the editor.

3 - No. This was just some text from the middle of spread sheet that I don't want to import the entire doc. Initially I was just taking the text straight from Excel and pasting it in but then later I copied it to a plain text editor, pasted it and then copied it again from there so that any formatting is gone. I also tried just plain old text typed into notepad, still doesn't work.

4 - We do but I tried this in Safe Mode and still have the exact same problem.

5 - I had been copying and pasting text just last week into pages without problem.

6 - I got it initially creating a page. Then I tried saving the page and then pasting the text in, same result.

7 - not sure what URL you're referring to, the 404 comes up in a pop-up with no address bar or anything useful in it. The browser address bar just shows the URL to the page I'm working on.

8 - checked the logs and even enabled diagnostic mode, the logs show nothing and I mean literally nothing when I get this so for some reason it isn't reaching the server at all.

I tried running it with IE's debugger on, F12, and all that is shown there is

LOG: AJS.Confluence: run binder components

LOG: Focus - starting requests

I then tried it on Firefox 21.0 and it works fine. So it appears to be an IE 9 issue as that is the version I have. Is there some setting within IE that could be causing this to not work? We did have some Windows updates recently that may have set something.

Thanks,

Jon

0 vote
David Simpson Community Champion May 21, 2013

Jon, Whats the URL of the '404ing' page? You should be able to right click on the page and view page info even in a popup without an address bar. This should give us a clue.

It shows url to our server /confluence/s/en_GB-1988229788/4224/875a2723d3ca93f267db5c35cdbfcf91f5910d.9/7b84f087691caad610711e0ffe6ab7c2/_/download/resources/com.atlassian.plugins.editor/tinymcesource/plugins/confluencepaste/pasteword.htm

We have the same problem using Confluence 5.1.1 and IE 8. Has anybody a solution, cause the disable/enable suggestion didn't work...

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

974 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you