Form Plugin - giving "lost email errors"

Hi , 

 

I am getting the above error message when submitting a form - this is occuring for a few of customers but not all - please see the attached error message. 

This has only started to happen after doing the most recent update - did not have an issue prior to doing this. 

Hope you can help - i have disabled and re-enabled the plug in

Thanks

Mike Form Plugin Issue.PNG

10 answers

Hi all,

We've just released a new version of Forms for Confluence that besides other features, should fix the the issues clients were having with SMTP.
Could you please update and let me know if it fixed all your problems?
Thanks,
Rafael

Hey, thanks for the update!

We have noticed two new issues however. 

First off, database entries seem to be created twice when submitting a form to a database (the same entry just shows up twice with the exact same timestamp in the results panel in the admin dashboard, even though the form elements on the creating site are only present once). 

Secondly, when you try to enter an E-Mail address in the form destination field we always get the "Lost Emails" error now (even though the sending address is of the correct domain).

Would be great if you could take a look at these and get back to us.

Thanks,

Benedikt

Hi @Benedikt Putz,

 

Hope this finds you well.  Please visit our website and log your enquiry via our contact form in our website, so that we can handle this enquiry through our formal process and ensure we can address this matter correctly.  While creating a ticket if you can provide us with the following information it will help speed up the process:

The version of Confluence & Forms for Confluence you are using

Please send us all the information that will help us replicate your issue at our end. If you are seeing "Lost Emails" error, please double check if your Mail Server has been configured correctly.
Kind Regards
Divya Margani | QA & Support Analyst | Adaptavist

Hi Nic, 

Yes its an adaptavist form plugin - thanks that would be great

Mike 

Hi Mike, My name is Rafael Franco, I'm the Tech Lead for the Product Team here at Adaptavist. I'm sorry to hear that you're having problems with Forms for Confluence. Can you please tell me which version you have installed? Also it would be helpful if you could send the logs when this error occurs, together with the version of Confluence being used. You can mail mail me in rfranco@adaptavist.com Thank you, Rafael Franco

0 vote

Is this the Adaptavist Forms add-on? If not, then you might want to explain which one it is. (If it is, then I can poke an Adaptavist for you - it's not my field, but I know who to ask!)

Hi Rafael - do you have an update on this?

I emailed you the information directly?

 

MIKE

Hi Mike, I did got your reply, but it seems I never received your logs which I do need in order to investigate. Do you reckon you could send them to my email address? Cheers

I will send the file directly to you. 

Hi Rafael, 

 

I am unable to send you the support file as its too large and for some reason I am unable to attached it to the comment (error message saying the server is not available) - which file do you need from the support log and i will send you that directly?

Mike 

Hi Rafael, 

Have you seen the messages I have been sending to you re the support logs?

Unfortunately i cannot send you the zip support file due to a restriction on my side with the size of the file i can send - can you suggest an alternative ie. dropbox or anything I can provide to help you look into this issue?

We are still encountering the problem?

A quick response would be much appreciated. 

 

Mike

Hi Mike,

Yes, please use dropbox and send me the link so I can download it, that's fine.

Cheers,

Rafael

Hi, 

I have just shared the file with you via dropbox to your email address. Please let me know if you have not received it?

 

Mike 

Mike,

I'm downloading the file, will let you know once I analysed it.

Cheers,

Rafael

Any news on this issue?

Hi Benedikt,

The reason for this error is that some people don't have their email address verified.
Can you confirm if the user that is trying to submit the Form has his email verified in the SMTP server? If not, then he'll not be able to send emails using forms for confluence.
This behaviour changed slightly in the last version. Before, he would always send an email as being the user configured in the forms for confluence config mail, but now it acts correctly and sends emails from the user that submitted the form, thus the error.
We're close to release another version that contains new features, and also in this case, it tries to send the email on behalf of the user that is submitting the form, if there's an error, he falls back to the user configured in the Forms Configuration to avoid any errors.
Let me know if I can further help.
Regards,
Rafael

Hi,

I have just done the update and will let you know if this resolved the issue - at present we are not seeing it, so hopefully thats a good sign. 

 

Mike 

Hi Rafael, 

We are still getting the "lost email" error occurring despite installing the recent update. 

Attach is the error log. 

 

Mike

Hi Mike,

I've took a look at the logs and I can't see any reference to Forms for Confluence. 

Can you send me the logs just after you submit the Form?

Thanks,

Rafael

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

478 views 19 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you