Extra paragraph in th

Hi, I have a user macro that outputs two spans. When this macro is inserted in a th, there is a <p>&nbsp;</p> at the beginning of the th and at the end. I removed from the source editor but once I save the page they are back.

Regards

Nelson

1 answer

1 accepted

This widget could not be displayed.
Davin Studer Community Champion Jun 02, 2014

If it is automatically putting it back in you might be able to craft some css to set the display on them to none and include it in your user macro. A hack I know, but it might get the job done. Such as ...

th p:first-child, th p:last-child {
    display: none;
}

Or you could remove them with javascript on page load. Again, you could put the JS in your user macro to do this.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

588 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you