It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
  • Community
  • Products
  • Confluence
  • Questions
  • Error occurred during template rendering: Invocation of method 'getHtml' in class com.atlassian.confluence.plugin.descriptor.web.ConfluenceWebInterfaceManager

Error occurred during template rendering: Invocation of method 'getHtml' in class com.atlassian.confluence.plugin.descriptor.web.ConfluenceWebInterfaceManager

After upgrading from confluence 5.5 (server) to 5.9.2 confluence seem to start up like it should, but trying to reach the web interface i only see:

Error occurred during template rendering: Invocation of method 'getHtml' in class com.atlassian.confluence.plugin.descriptor.web.ConfluenceWebInterfaceManager$ExceptionHandlingWebPanel threw exception java.lang.LinkageError: loader constraint violation: when resolving method "com.atlassian.confluence.util.velocity.VelocityUtils.getRenderedTemplate(Ljava/lang/String;Lorg/apache/velocity/context/Context;)Ljava/lang/String;" the class loader (instance of org/apache/felix/framework/BundleWiringImpl$BundleClassLoaderJava5) of the current class, de/nielsjaeckel/confluence/plugins/universalnavigation/renderer/HtmlListRenderer, and the class loader (instance of org/apache/catalina/loader/WebappClassLoader) for the method's defining class, com/atlassian/confluence/util/velocity/VelocityUtils, have different Class objects for the type org/apache/velocity/context/Context used in the signature at template/includes/macros.vm[line 1451, column 20]. Contact your administrator for assistance.

Among other bugs i noticed that all files were overwritten by root (which the installer demanded), so i have chowned both application directory and installation directory to the right user again, however same message on restart.

The error seems to refer to https://ecosystem.atlassian.net/browse/ATR-42 but i don't see a solution, just that it's fixed. I also attempted reaching the addon's on http://<our.confluence.address>:8090/plugins/servlet/upm#compatibility but this renders the same error screen as above.

I also attempted copying back the old server.xml which contained a few modifications (opening several http/https connectors), but all ports opened report the same error.

Have anyone seen this error before? Thankful for anything that might lead me right.


 

 

1 answer

1 accepted

2 votes
Answer accepted

Broken plugin, solved by support in less than 1hour!!

Could you please share the solution?

In this case, issue was caused by this plugin: https://marketplace.atlassian.com/plugins/de.nielsjaeckel.universal-navigation.plugin/server/overview

Disabling plugin fixed issue.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published Thursday in Confluence

Confluence CVEs and common questions

Two vulnerabilities have been published for Confluence Server and Data Center recently: March 20, 2019 CVE-2019-3395 / CVE-2019-3396 April 17, 2019 CVE-2019-3398 The goal of this article is...

297 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you