Error in creating application link between Jira and Confluence Edited

Hi ,

Application link is between Jira and Confluence is creating successfully but it is not listing in the application list in Jira while the same is visible and status is connected in Confluence side.

Error : /rest/applinks/1.0/listApplicationlinks [core.rest.ui.ListApplicationLinksUIResource] Exception:
java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: host must not be null
at com.atlassian.applinks.core.rest.ui.ListApplicationLinksUIResource.collectApplicationLinkStateResult(ListApplicationLinksUIResource.java:232)
at com.atlassian.applinks.core.rest.ui.ListApplicationLinksUIResource.getLinkAndAuthProviderEntity(ListApplicationLinksUIResource.java:162)
at com.atlassian.applinks.core.rest.ui.ListApplicationLinksUIResource$2$1.callWithContext(ListApplicationLinksUIResource.java:250)
at com.atlassian.applinks.core.rest.ui.ListApplicationLinksUIResource$2$1.callWithContext(ListApplicationLinksUIResource.java:244)
at com.atlassian.applinks.core.rest.ui.ListApplicationLinksUIResource$CurrentContextAwareCallable.call(ListApplicationLinksUIResource.java:285)
at com.atlassian.sal.core.executor.ThreadLocalDelegateCallable.call(ThreadLocalDelegateCallable.java:42)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: host must not be null
at java.util.concurrent.FutureTask$Sync.innerGet(Unknown Source)
at java.util.concurrent.FutureTask.get(Unknown Source)
at com.atlassian.applinks.core.rest.ui.ListApplicationLinksUIResource.collectApplicationLinkStateResult(ListApplicationLinksUIResource.java:224)
... 10 more

 

Jira gadgets are also not available in confluence side.

 

Jira Version : 6.2.7

Confluence Version :6.3.1

 

1 answer

0 vote
Micky Caritte Community Champion Nov 29, 2017

Hi,

I'm pretty sure you're facing an issue which is already known and good news is that here's a workaround!

Here is the knowledge base article to help you fixing that: https://confluence.atlassian.com/kb/cannot-retrieve-link-and-provider-entity-when-creating-application-link-827117142.html

The idea is that your Jira version is using a different version of SAL (Core component) than your Confluence version and it's known to cause issues with Tomcat. All details are explaine in the KB Article, hope you'll be able to troubleshoot that!

Cheers

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

872 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you