Error in Confluence logs: "The supplied editor content could not be converted to storage format"

Hi,

A user filed a ticket as he can't publish a page. Pretty normal page upon checking, with text and images snipped to the page.

You can't previous and update the page though. Clicking update will tell you there is an error so I dived in the logs and saw that message.

Any help would be greatly appreciated.

 

Kind regards,

Francis

1 answer

0 vote

Hi Francis,

By any chance, was the content copy and pasted from anywhere else in order to create the page? 

If you were to make a copy of the page, are you able to preview and save that?

Please also confirm your Confluence version with me.

Thank you!

Regards,

Shannon

Hi Shannon,

Thanks for getting back to me. I know this isn't the official support channel but glad to know the Atlassian team is here as well.

Current confluence version is 6.2.3. Its a bit off from the latest and we've been holding back upgrades due to issues with our DB (not supported anymore), but we are fixing that soon.

The user hasn't gotten back to me, and I assume he must have resolved the issue. I pointed him to a community post that outlined what others did to resolve the issue (new page and upload the content again) and hasn't come back to me again (might have worked and didn't bother anymore to reply to IT support queries).

An interesting suggestion though on copying the page. The thing is the page wasn't being published yet so we couldn't do it. We couldn't even view source of the page.

Let me know if you need more information.

 

Kind regards,

Francis

Had a look, issue has been resolved as the user just created a new page and deleted the old one. :)

Cheers,

Francis

Francis,

Great to hear! The reason I asked about copy/paste is when you get content from another location it sometimes copies things besides the text you can see, and it could cause errors like that. So it's probably the reason a new page worked fine.

Take care, and have a pleasant weekend.

Regards,

Shannon

Noted, Shannon, thanks. 

The user was an experienced Confluence user and just clips images from another site and pasted it on the page (which I normally do in most cases). It was just weird that it wasn't working this time, though we're glad creating a new page and doing it again worked.

 

Kind regards,

Francis

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

377 views 16 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you