During installation: Set up step error

During installation: set-up step error.

Something went wrong during installation after key generation.

Than following error occurred.

Tried to uniinstall,

tried to go to a reparation point before installation.

But always getting the same error.

JIRA already installed on same PC.

WIndowas 64 bit version.

9 answers

This widget could not be displayed.

I experienced this error, but was able to recover by:

  1. uninstalling
  2. shift-right-clicking on installer, clicking "Run as Administrator"

My hunch is that Windows' User Access Control (UAC) is creating problems with file permissions for the installer.

This widget could not be displayed.

I would recommend you to go to the Atlassian Support and create a issue there so they can give you a better tracking of this matter.

This widget could not be displayed.

I'm having the same problem.

This widget could not be displayed.

I avoided the problem by installing a previous version (4.1.9) - that installation was smooth...

This widget could not be displayed.

Tried that, still no luck - but this time I received a log.

This widget could not be displayed.

Hi there,

had the same problem in different OS-Settings, involving both x86 and x64 environments. Quite unsystematically though, because in an aother almost identical installation alll worked well.

And, sorry to say, "try support" ist too weak an answer. Time is valuable. Why is there no quick answer, in particular to a problem that does NOT seem to be an individual fault or error...?!

So, constructively speaking, PLEASE give us an answer here and now.

That's what such platforms are for.

Please do not get me wrong: The product is suberb!

THIS is the reason I am a little "un-patient"...

All the best

MArtin

Hi Martin,

Have you got any more details on the error message? I'm not sure if it's a problem at my end, but I can't see any error details on this thread. If there's nothing being reported on screen during the install there should be something in <Confluence Home>/logs/atlassian-confluence.log

Thanks,

Andrew.

This widget could not be displayed.

Hi Andrew,

thanks for your immediate reaction!! Very kind.

1. Your question/my immediate problem

Not knowing more than just "set up step error" (no further indication, nothing) was part of my problem: I couldn't do nothin, couldn't find nothing. De-Installation and Re-installation: to no avail.

2. technical ambience:

x86 2008-server, 3.5 GB RAM, 4cores. hosted with VM-Ware on a 4 core i5 PC as a testing environment. Updates installed.

This is meant to be my testing equipment while on the road. That is also the reason for the rahte "meager" or lean equipment (32bit instead of 64bit; reardless of the RAM restriction) .

3. Addtional question

How would I proceed in case i wanted to use Confluence not inhouse and not on a dedicated webserver (of our own), but with a www hoster (such as www.one.com" in Danmark; who allow for MySQL, PHP etc.)?

4. Background

I am testing Confluence a. to be able to use it for customers (eventually to become a reseller for your coompany) and b. to modell one of the key project of our Swiss company on it, a project which might eventually be calles "midsize excellence"... most certainly in collaboration mith a number of Universities wordlwide...

Thence the urgency.

Was this helpful?

Do you need more?

Thanks in advance

Martin

Ah, ok. Closest I could find relating to the behaviour you're describing are these bugs reports:

https://jira.atlassian.com/browse/CONF-18394

https://jira.atlassian.com/browse/CONF-18381

https://jira.atlassian.com/browse/CONF-18412

which can happen after you try and install the demonstration site. If that sounds similar to what you're seeing there are workarounds detailed in the bug reports.

Also, with re-installs are you completely removing the <Confluence Installation> and <Confluence Home> directories and dropping/recreating the database? Not always necessary, but that's what I would do with a failed install with no errors as there could be something lurking from a previous install that could cause it to fail again.

The spec of your test environment seems fine to me, but you might want to have a look at some details of running Confluence in virtualised environments:

http://confluence.atlassian.com/display/DOC/Running+Confluence+in+a+Virtualised+Environment

http://forums.atlassian.com/thread.jspa?threadID=21358

For future sizing you may find http://confluence.atlassian.com/display/DOC/Server+Hardware+Requirements+Guide and http://confluence.atlassian.com/display/DOC/Example+Size+and+Hardware+Specifications+From+Customer+Survey useful.

For hosting Confluence on an external server you need to find a provider that offers Java, http://confluence.atlassian.com/display/DISC/List+Of+Confluence+and+JIRA+Hosting+Providers is a good place to start looking for providers that can help. Other options are Rackspace Cloud, Amazon EC2 and Linode.

Hope that helps?

Andrew.

This widget could not be displayed.

I am doing a fresh install on a laptop with both JIRA and Confluence. There was a suggestion to remove the "felix" folder that is part of C:\Atlassian\Application Data\Confluence\plugins-osgi-cache\. I removed the entire three folders. If this does not work then I will try the uninstall-reinstall as an admin. as depicted above using "run as adminstrator".

This widget could not be displayed.

Hi all, I had the exact same problem. Found out installing Java was the solution..!!

So uninstall the non-responsive installation, delete your Atlassion dir and install Java first, this worked for me at least.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

409 views 4 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you