Dragon Slaying - Should I stick to Confluence 3.5.7 or take the latest Confluence 3.5 version?

The instructions in Dragon Slaying Stage 3 Step 2 say that I should use Confluence 3.5.7 (released June 22, 2011). The latest available Confluence 3.5 version is 3.5.13 (released September 1, 2011). Should I stick to 3.5.7 or should I use 3.5.13, which I guess only adds stability?

6 answers

1 accepted

This widget could not be displayed.
Joe Clark Atlassian Team Feb 02, 2012

There shouldn't be any problems using 3.5.13 instead.

This widget could not be displayed.
In case you want to go for the latest and greatest I did Dragon Slayer with 4.1 (just for fun) and can confirm it all works and didn't have to deviate from the instructions.
This widget could not be displayed.

Thanks for the answers. 3.5.7 config blows up on not being able to create the tables in the database. I might wipe it all and try 4.1

This widget could not be displayed.

What error did you get with creating tables? When the install falls over at table creation it's normally due to one of:

  • Database doesn't exist
  • DB exists, but isn't empty
  • Wrong username/password
  • Insufficient privileges for the DB user
  • Typo in the JDBC URL
  • Connection problem between server and DB (if they're on different machines)

Andrew.

This widget could not be displayed.

I didn't keep the error message's details but it just said that it can't find the tables inside. Maybe it though that it managed to create them in a previous run (which is marked in a local text file).

  • Database already exists and with right access permissions for that user
  • Database was empty
  • Username/password were verified using "psql".
  • Double-checked privileges for that user (it's the database owner and was able to add roles and tables as instructed)
  • URL was verifies
  • Database was on same host.

All of these were verified with psql.

I dropped and re-created the database but it didn't help.

I eventually dug up and installed JDK 1.6 (6?) instead of 7 and it started working (1.6 takes a little bit of digging in order to find on Oracle's web site).

I was later told that I should actually use 1.6 for everything since this is what all Atlassian products require.

The instructions in http://confluence.atlassian.com/display/ATLAS/Dragons+Stage+1+-+Install+JIRA#DragonsStage1-InstallJIRA-Step1InstallJava clearly say "Oracle JDK 1.6 or higher", which I interpreted to include JDK 7, I was now told that it was supposed to mean "1.6.x for any x".

Thanks everyone for your responses.

This widget could not be displayed.
Joe Clark Atlassian Team Feb 12, 2012

Ah, I think that documentation was written pre Java 7. I'll see if I can get it updated.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

473 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you