Disable the login box pop-up when on iPhone&Safari

https://jira.atlassian.com/browse/CONFSERVER-43775

 

I've disabled the confluence mobile plugin, but our users still see the non-functional login pop-up when using safari on their iphones.

I've been trying to simulate an iphone/safari experience in a browser that has developer tools, so I can track down how to block/disable the popup with custom code, but so far no luck.  User Agent switchers, online 'iphone simulator sites', nothing seems to trigger the pop-up in a browser , except really being on an iphone.

Question:  does anyone have a way to disable the broken login pop-up?  None of the suggested methods in the several different 'issue' pages about this have worked for us.

 

2 answers

This widget could not be displayed.

Hi Jason,

That issue was resolved in Confluence 6.0.2 according to the main bug ticket:

My best recommendation would be to upgrade to that version. The other option of a workaround is to use a different browser on your phone if disabling the add-on didn't work.

In terms of troubleshooting in a browser, is Safari emulation not working for some reason? I assume you've tried that, and it doesn't replicate the pop-up for you.

However, If you don't have it turned on, you can go to Safari > Preferences... > Advanced. At the bottom, you'll see Show develop menu in menu bar. Then you'll have a Develop menu, and you can select User Agent and select how you want pages to load, including as if they were on iOS 10.

Kind Regards,
Shannon

None of the User Agent switchers I've tried have triggered the login box pop-up.   Firefox has a a lot of plugins to make itself appear to be an iphone/safari, but confluence must be using more than just user agents to decide when to throw that pop-up.

I've also tried the Develop tool bar agent switcher in Safari on the destkop, and it can't trick confluence into thinking its on a iphone either.  

Since upgrading is going to take some time,  I figured I could hide the box if I could get the generated source code.  

I've also found a few ways to see the source code in safari on an iphone , like bookmarking some JS:  https://ole.michelsen.dk/viewsource/bookmarklet.min.js  , but none of them show the generated source, only the original.  

This widget could not be displayed.

This issue is back with version 6.7.1.  :(

Jason,

I would recommend commenting on the original bug ticket as it seems other users are having the same issue lately.

I've also commented there and provided the feedback to our developers in an Atlassian-side comment.

Regards,
Shannon

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

400 views 4 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you