It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Copy-paste doesn't work in Confluence

Hi All,

many of our Confluence users complain that they cannot paste text from the clipboard to Confluence.

They use IE9, and our Confluence version is 4.3.2

Can you please help?

Thanks,

Rumi

4 answers

1 accepted

1 vote
Answer accepted

I've seen a similar issue and basically the root cause was a third-party plugin that blocked the rich text format to be copiied.

Just for test purpose you can try running Confluence in "safe mode" as we can see here:

https://confluence.atlassian.com/display/CONF35/Disabling+or+Enabling+a+Plugin#DisablingorEnablingaPlugin-Disabling/EnablingallUserInstalledPlugins%28SafeMode%29

RUnning in safe mode will disable all third-parties plugins, so in this we we can narrow down this issue.

Cheers,

Bernardo

Hello Rumi,

To give us a better idea about the scenario, could you please let us know the exact steps that your users are performing? Also, please check at your 'atlassian-confluence.log' (<confluence-home-directory>/logs folder) and take a look at the end of the file and see if there's some specific error stack-trace, if so please paste it here for us, so we can have a better idea about the problem.

And please, check the following points at your instance regarding customizations(this can be also affecting here):

- Confluence Admin > Look and Feel* and *Space Admin > Look and Feel*, then verify the following:

* Themes: See which theme you're using, switch back to the default if you're not using it already.
* Layouts: See if you have any custom layout defined, if yes then make a backup and reset to default.
* Stylesheet: See if you have custom stylesheet, if yes then make a backup and reset to default.
* Custom HTML: See if you have any custom HTML defined, if yes then reset to default

Kind Regards,

LJ.

The problem for me occurs in firefox when I've modified about:config:

dom.event.clipboardevents.enabled;false

ARG! It also disables pasting in these comments! I turn it to false to ALLOW pasting in many situations. Confluence and Atlassian community boards are the only place where the reverse is true. Super annoying that you disable pasting without modifying the content of the clipboard. If the reasoning is only to allow rich-text formatting, it only begs the problem of allowing me to work directly in the markup language instead of the forced WYSI(not-quite)WYG.

When I try command+V the bullet-list format is selected, but nothing else happens.

Agree. This is super-annoying. I want to have `dom.event.clipboardevents.enabled;false`

because it protects me before annoying feature in many sites:

when I'm selecting text and Ctrl-C it into clipboard many sites adds to text smth. like "More at: http://blah.com".

 

Now because of Confluencte behavior I can't unset above flag :(

Hello Rum,

I just tried to replicate this problem in my local Confluence, and I couldn't. Here is working fine. May I ask you, if this is happening with Chrome or Firefox as well?

Cheers,

WZ

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

3,139 views 4 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you