Confluence version 6.2 is having issue with preview,

The preview is showing only half of the page and is showing on the right hand side , not the full page

1 answer

0 vote

Hi Sojan,

Just a few questions:

  1. Can you show us a screenshot of what is happening?
  2. Do all users encounter the issue?
  3. Does this occur on certain browsers? Which ones have you been able to test with?
  4. Does this occur for all attachments, or only specific ones/types?

Thank you!

Kind Regards,
Shannon

I was checking the issue, it is because if I enter anything in Side , header and footer (Look and feel - [admin setting]). If i remove the code the preview works without any issue. See the below image , I placed a single line code to display the search control. It is happening in all the brower. The idea is to use an image as a header to appear in all pages. It is working fine is Ver 5.8. The problem is in 6.2.1 developer license.

Thanks

 

ConfluenceError.jpg

Hi Shannon, Did you get a chance to look into it.

Hi Sojan,

Apologies! I was on holiday since Saturday. 

Can you let me know exactly what you're entering in Look and Feel? I can test it on 6.2 but I'd like to use the code you're using to trigger it. Just let me know what code you use and exactly where so I can replicate.

Can you also tell me what browser this occurs in? 

Kind Regards,
Shannon

I have replied in the email. Please let know ASAP. We have a meeting tomorrow to decide on upgrade. 

Sojan,

My apologies - see it happens in all browsers.  You can confirm they are all the most recent version, correct? 

In regards to your email, I am not sure which email you are referring to. I previously asked to see the code you're using to trigger this but I don't see that I have received that. Could you please show me the exact code you have entered so I can have a look?

Kind Regards,
Shannon

Hi Shannon,

 It was my mistake , I send it to no reply email

Thanks for the reply,  we were having some html code in 5.10.7 (which is our current version) and is working fine when previewing a page after editing

Now we have updated on our test server from 5.10.7 to 6.2.1 and we found we have issue with the page preview. So removed all the header footer as below, and the preview works fine.

 Ac1.png

 

Instead of the whole html, I just place one line of code the live search (just for testing) as below.

 
{livesearch:spaceKey=bqc}

ac2.png

 

After saving the setting , went on a page , edit, preview. See the below image. This is happening in all the browsers. Hope this explains everything.

ac3.png

Or you just try adding html to header, and preview it.

Got it! Thank you for your explanation.

I've been able to replicate this in both 6.2.1 and 6.4.1, so it seems to be a current bug. I found the following issues:

The first was created initially, and the 2nd may be a duplicate but has more details.

My recommendation is to vote on and watch both and one may be merged into another. The vote helps us keep track of how many users have run into the problem. At this time there's no workaround besides, as you've discovered, to remove the customizations.

Let us know if you have any additional questions.

Kind Regards,
Shannon

Thanks Shannon, It seems I need wait for the wait. Anyway I have voted on both.

Thanks,

Sojan

Thank you for your assistance, Sojan!

Take care and have a pleasant rest of your week.

Kind Regards,
Shannon

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

1,159 views 22 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you