Confluence upgrade failure

Hi Team,

I tried upgrading Confluence fron 5.1.3 to 5.4.1. When upgrade was complete, i opened the confluence site and i found this error " Build version number in application server is different from the build version number in database".

After searching through the KB i found this link https://confluence.atlassian.com/display/CONFKB/Confluence+will+not+start+up+because+the+build+number+in+the+home+directory+doesn%27t+match+the+build+number+in+the+database,+after+upgrade

and tried the resolution, but still i am facing the same error. Please help me out with this.

1 answer

Hi Sharath,

That usually happens when you had a failed upgrade attempt and then you try to upgrade again without restoring your Confluence to a state prior the first attempt.

It's possible for you to restore the application directories and the database to macht with Confluence in version 5.1.3?

If it is, after that is done try to upgrade again and see what kind of error you get.

Thanks and Regards,
David|Atlassian Support

Hi Deividi,

I upgraded the confluence from 5.1.3 to 5.4.1 then i got tis error, i restored the database from the previous night's backup. Then i downgraded the confluence from 5.4.1 to 5.1.3 successfully.

After a week i tried to update again, still i am getting the same error. So had to backout to 5.1.3 only.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,601 views 4 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you