Confluence upgrade error

Hello

I am upgrading confluence from 3.0.2 to 4.2.6

I see this error in atlassian-confluence.log Can you please let me know how to resolve.

( I did a backup in 3.0.2 with backup attachments option checked, I got a zip file. I am restoring in 4.2.6 using this zip file.)

2012-06-29 12:43:46,471 ERROR [Indexer: 2] [apache.pdfbox.filter.FlateFilter] decode Stop reading corrupt stream
-- referer: http://localhost:8090/admin/backup.action | url: /admin/restore-local-file.action | userName: admin | action: restore-local-file
2012-06-29 12:43:49,618 ERROR [Indexer: 2] [apache.pdfbox.filter.FlateFilter] decode Stop reading corrupt stream
-- referer: http://localhost:8090/admin/backup.action | url: /admin/restore-local-file.action | userName: admin | action: restore-local-file

Thanks

Abe

3 answers

1 accepted

This widget could not be displayed.

Hi Abraham,

Unfortunately upgrades are not as simple as that as backup export/import only works if both the source and target Confluence versions are the same.

For a general overview of upgrades have a look at https://confluence.atlassian.com/display/DOC/Upgrading+Confluence and https://confluence.atlassian.com/display/DOC/Upgrading+Confluence+Manually , but going from 3.0.2 you're going to have to do some intermediate upgrades:

3.0.2 -> 3.3.3 -> 3.5.17 -> 4.2.6

You might be able to skip the 3.3.3 step, but you are going to need the intermediate 3.5.17 step as there were major updates in 3.5 and you can't jump that many versions in one go.

Hope that helps?

Andrew.

This widget could not be displayed.
Peter Koczan Atlassian Team Jan 24, 2013

For future reference, based on Jozef's link, I have created a KB for this issue that you can find here: https://confluence.atlassian.com/pages/viewpage.action?pageId=319389981

This widget could not be displayed.

Hi Abraham,

we also had many of these "decode Stop reading corrupt stream" issues when indexing in Confluence 4.3.2. For me replacing pdfbox-1.6.0.jar with pdfbox-1.7.1.jar stopped the issues from appearing.

You could try that, but I think it is not officially supported by Atlassian because Confluence 4.3.x is delivered with version 1.6.0.

Regards Michael

IMHO the real root cause is swallowed OutOfMemory Exception - see my comment in CONF-27115 - request for packaging newer PDFBox into Confluence

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

459 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you