Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence tomcat connector will not start listening on redirector port 9446 on service start

Confluence tomcat connector will not start listening on redirector port 9446 on service start.

We've tried switching the port number but same results.

Here is the server.xml below.

Tomcat starts and we can connect on 8092.  So its not that all ports aren't working, its just 9446. We have an old instance that works but unable to get the new one working.

 

<?xml version="1.0"?>
<!-- Ansible managed -->
<Server port="8001" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<Connector URIEncoding="UTF-8" acceptCount="10" connectionTimeout="20000" debug="0" enableLookups="false" maxThreads="48" minSpareThreads="10" port="8092" protocol="org.apache.coyote.http11.Http11NioProtocol" redirectPort="9446"/>
<Engine name="Standalone" defaultHost="localhost" debug="0">
<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false" startStopThreads="4">
<Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
<Manager pathname=""/>
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60"/>
</Context>
<Context path="${confluence.context.path}/synchrony-proxy" docBase="../synchrony-proxy" debug="0" reloadable="false" useHttpOnly="true">
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60"/>
</Context>
</Host>
</Engine>

 

<Connector port="9446" maxHttpHeaderSize="8192"
maxThreads="150" minSpareThreads="25"
protocol="org.apache.coyote.http11.Http11NioProtocol"
enableLookups="false" disableUploadTimeout="true"
acceptCount="100" scheme="https" secure="true"
clientAuth="false" sslProtocols="TLSv1.2" sslEnabledProtocols="TLSv1.2" SSLEnabled="true"
URIEncoding="UTF-8" keystoreFile="/app/confluence-rmakp/keystore/confluence.keystore"
keystorePass="changeit" keyAlias="rmakp-staging" />

 

</Service>
</Server>

 

1 answer

0 votes
Pramodh M Community Leader Jan 15, 2022

Hi @Bruce Guy 

You can specify the port when installing Confluence, try re-installing confluence and give the input port 9446

If you have solved the issue, feel free to post the answer!!

Thanks,
Pramodh

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.4.11
TAGS
Community showcase
Published in Confluence Cloud

🏠 Say hello to the new Confluence Home!

Hi Atlassian Community, My name is DJ Chung, and I’m a Product Manager on the Confluence Cloud team. Today, I’m excited to share a new and improved version of Home. The new Home helps you ...

38,344 views 28 126
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you