Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence stopped updating the index - rebuilding & rebuilding from scratch does not resolve

Our Confluence server stopped updating the dashboard, which appears to indicate issues with content indexing. The same root cause is probably also responsible that users are unable to find new content via search and some plugins stopped working correctly. 

This severely affects our routine use of Confluence!

I have tried to manually rebuild the index which seems to get the index sync'ed to the current content, but then any new content is not considered until I manually update the index again.

I have also tried to manually rebuild the index from scratch (stopping confluence and deleting folders, then rebuilding the index), which did not solve the problem either.

I tried to review the Confluence log, but found the output to be inconclusive. Rebuilding the index itself, does not seem to trigger any errors, but there is some complex output while using the system - which may or may not be related, and even if related, may simply indicate follow-up errors due to index issues.

I hope someone can assist with troubleshooting this issue. The instance is currently on 6.15 and I am considering an update to 7.x. Not sure if that would simply resolve the issue or just make it worse, though.

3 answers

This is a very interesting issue . I'd love to here how you'd get this resolved.

Have you read the following ;

https://confluence.atlassian.com/doc/content-index-administration-148844.html 

1) Could be your search indexing process is slow ?

2) Could be your memory is low ?

There could be so many reasons - but basically your content/search indexing is slow or not happening at all.

Your insufficient heap memory could also be the reason why your automatic indexing is ineffective.

 

https://confluence.atlassian.com/confkb/automatic-indexing-not-working-789095505.html

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

408 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you