Confluence server, add link to page and save makes link to open page in edit mode Edited

Hello.

Confluence server sits behind proxy.

First base_url was configured ti server ip address.

Then we changed base_url to domain address.

After this when inserting link to a page created before base_url change after saving open the link in page edit mode. Back in source page edit link edit is greyed out.

During insert the link shows as view page. 

If after inserting such a link save the destination page - it opens in view mode.

As well if linking to hte page created after base_url change - everything works fine.

2 answers

This widget could not be displayed.
Ann Worley Atlassian Team Jan 23, 2018

Hi Dmitry,

It sounds like you are running into behavior related to these bugs: Editing a page after changing the base URL causes all page links and @mentions to become links to the page itself and Images, attachments and user mentions in the page are broken after changing the BaseURL

In both cases, the workaround is to disable and re-enable the Collaborative editing feature. This is less than ideal because: 

  1. The issue will stop occurring but you will need to go back and manually restore any pages that were affected.
  2. All existing shared drafts are lost when you switch collaborative editing off, so make sure your users have published any work they want to keep before you make the change.

Please vote and/or comment on the bug reports to add weight to them. Here is our Bug Fixing Policy with more info on how we prioritize bug fixes

Thanks,

Ann

@Ann Worley thanks for reply and options to check.

Unfortunately these links does not solve the issue I have.

Ann Worley Atlassian Team Jan 23, 2018

Hi Dmitry,

I realize the descriptions on the bug reports don't mention the attachment view link URL being changed to an edit URL, but they are close enough to the symptoms and situation (attachment links are not behaving as expected after base URL change) to be fixed by the same workaround.

Did you turn collaborative editing off and back on and still see the issue? If you toggled collaborative editing mode and are still seeing the issue, please let me know and I will research more.

If you haven't tried the workaround because of the shared drafts, perhaps you can reproduce the issue in a test instance, and try the workaround there, to save your users some trouble.

Thanks,

Ann

@Ann Worley I followed the workaround instructions but this did not help.

This widget could not be displayed.

Some more details:

Add link to page

conf1.png

Check the added link is viewpage.action:

conf2.png

 

Update the page and check the link is createpage.action:

conf3.png

Ann Worley Atlassian Team Jan 24, 2018

Those are good screenshots, I see what you mean. I opened a support request on your behalf so we can take a closer look. After we resolve it there we can post back to this thread to let the Community know the resolution.

@Ann Worley thank you very much.

waiting for solution.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

601 views 8 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you