Confluence search problem - how do you turn off 'fuzzy' matching?

As far as I am aware our Confluence instance is set up with the default search indexing. My colleagues are having problems with the search because it is reporting many pages which are not exact matches to the required search term. For example:

A search for "severity" also finds "several". I have been trying to work out how to disable this 'fuzzy' matching but cannot find anything in the admin options or in the Help. It seems rather odd that the Confluence Search Syntax page explains how to use "~" to do a fuzzy search if it does this by default.

I'm probably just looking in the wrong place but would be very grateful for your help finding out how to turn this off.

1 answer

1 accepted

0 votes
Accepted answer

Hi Felicity,

I suspect part of the problem here is how Confluence creates it's search index, which is managed by Lucene, because the content is "stemmed" when the content is indexed. You can read a short discussion about Lucene, stemming and wildcards here: http://stackoverflow.com/questions/11844722/stemming-wildcarding-unexpected-effects

Essentially the reason why "severity" also finds "several" is because when Lucene stems "severity" and "several", the stem that it retains is "sever" and as such both words are retained because Lucene also stems the input search term and then references it against the stems it knows before returning everything that it thinks are relevant, (which leads to these confusing results).

The only solutions to this that I'm aware of would be to configure an external tool to index Confluence and manage the content searching. You can read a bit about this in our documentation on the subject: https://confluence.atlassian.com/display/DOC/Setup+External+Search+Tool+To+Index+Confluence

All the best,
John

Thanks for your quick reply. It was very helpful. Having looked in Jira, I quite suprised to see how long this has been an issue that people have had problems with. One of the bugs that I found suggested changing the indexing language to "other" to turn off stop words and stemming, so I'm going to try this and see whether this helps (https://jira.atlassian.com/browse/CONF-3353).

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,031 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you