Confluence redirects to HTTP when using HTTPS/nginx setup

Hi,

I've followed the guide at https://confluence.atlassian.com/doc/running-confluence-over-ssl-or-https-161203.html and its been working fine for some months now. We recently setup a new office and access to the Confluence server is only allowed on port 443/HTTPS.

When a user edits a page and saves it, the save back request goes to:

https://wiki.domain.com/pages/doeditpage.action?pageId=123456

This has a Status Code of 302 Found, and Response Header of

Location: http://wiki.domain.com/display/SPACENAME/pagetitle

So the user is redirected to HTTP which is blocked, they receive a time out and then change to HTTPS and all is fine.

 

The Server Base URL is set as HTTPS and everything else works, emails have the HTTPS links etc. Is this a bug, or is there an extra setting I can change somewhere in the configs to not redirect to HTTP.

Thanks,

Paul.

1 answer

This widget could not be displayed.

Hi

 

I have the same configuration and the same problem.

Do you have stilll your problem?

 

I've a 302 redirect with http:// protocole instead of https

 

 

Regards, 

Olivier

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

269 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you