Confluence not loading until multiple Browser refresh (chrome and IE)

I tried multiple solutions from confluence guides (proxy) and faq, stackexchange-answers (about cache,static ip) ... but I am stuck:

The Environment:

Debian 8.6 // Confluence Server (6.0.1, with synchrony disabled) // Apache 2.4.10  with mod_proxy
Static external IP: 12.13.14.15:8443
Name: my-dummyserver.com:8443

ReverseProxy and SSL Settings according to the corresponding Confluence Guides.
The certificate ist issued to my-dummyserver.com:8443


From Home everyone can access confluende via 12.13.14.15:8443 (despite the certification error) and my-server.de:8443 but from company network:

  • my-server.com:8443 is not exessible due to internal DNS configuration *cant do anything against it)
  • https://12.13.14.15:8443 can be accessed with
    • firefox (win/linux) NO PROBLEMS
    • google-chrome (linux) - login is fast without problems, but then sometimes it gets stuck and site is loading infinitely, pressing F5 (refresh) two or three time -> the site load successfull

warning MAIN PROBLEM:

    • GoogleChrome (windows) - site is loading the dashboard fast, loads login form fast, after klicking login it loads infinitely until I hit F5 (refresh) multiple time. Then I can navigate some sites but it will stuck again, pressing F5 some times... success... and so on
    • same for InternetExplorer (accept the Site stuck on Login form - klicking "login"-button multiple times will load the site... and so on

It has to do something with out internal network and apache, but I can't find the problem.

I tried disabling compression on each site or both sites (apache and conflunece) - no success after restarting the browser.

Base URL is set to https://12.13.14.15:8443

 

server.xml
1         <Server port="8000" shutdown="SHUTDOWN" debug="0">
  2             <Service name="Tomcat-Standalone">
  3                 <Connector port="8090" connectionTimeout="20000" 
  4                         maxThreads="250" minSpareThreads="10"
  5                         enableLookups="false" acceptCount="100" debug="0" URIEncoding="UTF-8"
  6                         protocol="org.apache.coyote.http11.Http11NioProtocol" 
  7                         proxyName='12.13.14.15' proxyPort='8443' scheme='https' secure="true"
  8                         
  9                         useCipherSuitesOrder="true"
 10                         ciphers="TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256,
 11                         TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384,TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384,
 12                         TLS_DHE_RSA_WITH_AES_128_GCM_SHA256,TLS_DHE_DSS_WITH_AES_128_GCM_SHA256,
 13                         TLS_DHE_DSS_WITH_AES_256_GCM_SHA384,TLS_DHE_RSA_WITH_AES_256_GCM_SHA384,
 14                         TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256,
 15                         TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA,
 16                         TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384,TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384,
 17                         TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA,TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA,
 18                         TLS_DHE_RSA_WITH_AES_128_CBC_SHA256,TLS_DHE_RSA_WITH_AES_128_CBC_SHA,
 19                         TLS_DHE_DSS_WITH_AES_128_CBC_SHA256,TLS_DHE_RSA_WITH_AES_256_CBC_SHA256,
 20                         TLS_DHE_DSS_WITH_AES_256_CBC_SHA,TLS_DHE_RSA_WITH_AES_256_CBC_SHA,
 21                         TLS_RSA_WITH_AES_128_GCM_SHA256,TLS_RSA_WITH_AES_256_GCM_SHA384,
 22                         TLS_RSA_WITH_AES_128_CBC_SHA256,TLS_RSA_WITH_AES_256_CBC_SHA256,
 23                         TLS_RSA_WITH_AES_128_CBC_SHA,TLS_RSA_WITH_AES_256_CBC_SHA,
 24                         TLS_SRP_SHA_DSS_WITH_AES_256_CBC_SHA,TLS_SRP_SHA_RSA_WITH_AES_256_CBC_SHA,
 25                         TLS_SRP_SHA_WITH_AES_256_CBC_SHA,TLS_DHE_DSS_WITH_AES_256_CBC_SHA256,
 26                         TLS_SRP_SHA_DSS_WITH_AES_128_CBC_SHA,TLS_SRP_SHA_RSA_WITH_AES_128_CBC_SHA,
 27                         TLS_SRP_SHA_WITH_AES_128_CBC_SHA,TLS_DHE_DSS_WITH_AES_128_CBC_SHA,
 28                         TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA,TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA,
 29                         TLS_RSA_WITH_CAMELLIA_256_CBC_SHA,TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA,
 30                         TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA,TLS_RSA_WITH_CAMELLIA_128_CBC_SHA"                
 31                         
 32                         
 33                         />

 41         <Engine name="Standalone" defaultHost="localhost" debug="0">
 42 
 43                     <Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false">
 44 
 45 <!--original
 46                 <Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
 47 -->
 48                 <Context path="/" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
 49                     <Manager pathname="" />
 50                     <Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
 51                     <!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.prop
 52                 </Context>
 53             </Host>
 54 
 55         </Engine>
apache config
1 <VirtualHost *:8443>
  2         ServerAdmin webmaster@192.168.0.100
  3         DocumentRoot /var/www/html
  4 
  5         ServerName 12.13.14.15
  6 
  7         SSLEngine on
  8         SSLProtocol TLSv1.2
  9         SSLCertificateFile  /var/atlassian/application-data/confluence/_confluenceSSL/2_my-server.com.crt
 10         SSLCertificateKeyFile /var/atlassian/application-data/confluence/_confluenceSSL/apacheConfluencePriv.key
 11         SSLCertificateChainFile /var/atlassian/application-data/confluence/_confluenceSSL/1_root_bundle.crt
 12 
 13         ProxyRequests Off
 14         ProxyPreserveHost Off
 15         ProxyTimeout 600
 16         <Proxy *>
 17                 Require all granted
 18         </Proxy>
 19         <Location />
 20                 # Auth changes in 2.4 - see http://httpd.apache.org/docs/2.4/upgrading.html#run-time
 21             Require all granted
 22         </Location>
 23 
 24         ProxyPass /synchrony http://192.168.0.100:8091/synchrony
 25         <Location /synchrony>
 26             # Auth changes in 2.4 - see http://httpd.apache.org/docs/2.4/upgrading.html#run-time
 27             Require all granted
 28             RewriteEngine on
 29             RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
 30             RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
 31             RewriteRule .* ws://192.168.0.100:8091%{REQUEST_URI} [P]
 32         </Location>
 33 
 34 
 35         ProxyPass / http://192.168.0.100:8090/ retry=0 connectiontimeout=600 timeout=600
 36         ProxyPassReverse / http://192.168.0.100:8090/
 37 
 38 
 39         ErrorLog ${APACHE_LOG_DIR}/error.log
 40         CustomLog ${APACHE_LOG_DIR}/access.log combined
 41 </VirtualHost>
 42 
 43  
 44 <VirtualHost *:80>
 45         #ServerName 192.168.0.100
 46         #Redirect Permanent / https://192.168.0.100:8443/
 47         #Redirect Permanent /confluence https://192.168.0.100/confluence
 48 </VirtualHost>
 49

Can you help me please?

What is this strange "hit multiple times F5 (refresh) and it works" - thing?

(Same behavios on multiple Clients: Windows 10 with Chrome or IE and WinServer2012 with IE)

 

 



1 answer

1 accepted

after all... it WAS a problem with the processing of the certificat.
Firefox somehow works around it, but chrome and IE probably need the correct URL for the connection to work.

So after our admin got the subdomain and DNS to work correctly for internal and external access (https://confluence.my-server.com:8443) - it works

(I changed the apache and server - config files accordingly)

 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

372 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you