Confluence issue after upgrading from 3.5 to 4.2

I upgrade my confluence from 3.5 to 4.2. Everything went smoothly. I can view the contents with no problem after upgrading.

However, when I tried to modify a page, I kept getting the error message "Error saving draft. No draft has been saved." If I use the save function, the contents will be saved just fine.

When I tried to upload an image and user insert image function to insert it into a page, I will not be able to see anything in the page. I checked the log and found the image was uploaded correctly.

When I tried to insert a link, the search function is not working with the error message "There was an error communicating with the server, please try again later."

Anyone knows the possible reason for this? Thanks a lot in advance

5 answers

anything in the log?

just checked log. A lot of error message inside. Most seems to be related with "Could not initialize class com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder"

such as:

Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder

at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:431)

at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:288)

at com.sun.xml.bind.v2.runtime.JAXBContextImpl$JAXBContextBuilder.build(JAXBContextImpl.java:1111)

at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:154)

at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:121)

Hi Steve, It's hard to pinpoint the issue based on the stack trace you provided. Are you using the global theme? Is this happening to all spaces? You might want to raise a support ticket at https://support.atlassian.com with your latest logs so we can continue troubleshooting it.

Thanks for all your help.

I contacted tech support and figured out that it is due to the java installed on our server. The java used on our server is pretty old, 1.6.0.5. This is not compatible with the latest confluence. I upgraded the java to the latest 1.7.0 and it fixed all the issues.

Thanks again.

The java used on our server is 1.6.0.5. It works fine with confluence 3.5. However, it is not compatible with the latest confluence 4.2. We upgraded java on the server to 1.7.0 and this fixed all the issues.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Published 14 hours ago in Confluence

Think you know shares vs. @mentions in Confluence? Take this collab quiz.

To anyone who doubts that Atlassians are a little too obsessed with collaboration, and tools related thereto, let me describe a recent discussion we had (which took place on our internal Confluence, ...

99 views 2 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you