It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence failing DB collation and character set Health check

The health check in our self hosted Confluence installation is fail for the DB collation and character set.  Both have the same result message:

Exception during health check invocation java.lang.RuntimeException: java.sql.SQLException: You can't operate on a closed ResultSet!!!

I've trawled the web but can't seem to find anything on this.  

I should add we're running on Windows with MySQL 5.7 DB

Any ideas?

9 answers

1 accepted

2 votes
Answer accepted

Version 1.23.2 appears to have resolved this issue.

I have also upgraded to version 1.23.2 and it seems like the issue is solved.

Have upgraded and issue is resolved.  Thanks everyone

A defect already exists in the Atlassian Jira: https://jira.atlassian.com/browse/CONFSERVER-59375 .

Can confirm same behaviour on Linux as well also with MySQL 5.7 and Confluence 7.2.0 and 7.2.1. No apparent errors in the logs.

Also on another install which is still v 7.1.0 the same error.

And of course collation and character set is set according to documentation.

Same here, Confluence 7.2.0 on Debian 8 with MySQL 5.6.47.

It is a bug, after downgrading to 1.21.2 the messages are went away.

I downgraded

Atlassian Troubleshooting and Support Tools
to: 1.21.1
from: 1.23.1

 

and the messages went away, so possibly a bug?

Thanks for the replies.  It's good to know that it's not just something with our installation.  I couldn't find anything on google so I assumed it was an issue with our setup. 

As everything seems to be working okay I'll leave things for now and see if they push an update sometime soon.  if they don't, I'll consider downgrading.

We are having the same issue since upgrading the Atlassian Troubleshooting and Support Tools plugin last night, the Database and Server are both set correctly to UTF-8. I have raised a ticket to Atlassian already so hopefully they push out a patch or fix for this if it's a bug!

Hi, there's an update for the "troubleshooting and support tools" app in Confluence - after the upgrade to v1.23.2 the issue was gone!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,340 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you