Confluence editor probs - tiny edit window or text in blocks

I'm suddenly having a really really weird problem editing pages. This is happening on two different sites (both on the same server), one running 5.02 and the other 4.1.3.

I first noticed the problem yesterday when I tried to paste in some text from one of my old web sites as retrieved from the Wayback Machine (web.archive.org). When I pasted the text into a new document (using Chrome) the text did appear, but the actual editing area was only 150 pixels tall with a scroll bar. So I could see all the text, but only a little bit at a time.

I thought it must have something to do with the text I was pasting, so I tried dumping it into Notepad first, copying bits at a time. Same problem, so I gave up.

Later in the day I edited a page I'd started the day before and I found that I had the same problem - tiny little editor window.

I fired up IE. In IE I could see the editor window as normal, but each paragraph was in its own text block, with grab handles.

I tried editing older pages. Same problem.

I restarted Confluence. Same problem.

I rebooted my own machine. Same problem.

I rebooted the server. Same problem.

All of this was in the 5.0.2 site. So I tried the 4.1.3 site - same problem.

I tried both IE and Chrome on a completely different computer - same problem.

I tried a hosted Confluence site I have and that works fine. So it would appear it's not my browsers.

I'm really baffled. It must be something on the server, but what would affect both sites? They're completely separate installations. Nothing has changed on the server recently.

Any and all suggestions greatly appreciated.

Dave

4 answers

1 accepted

1 vote

This is a problem introduced by Chrome v27.

We have provided a plugin which you can install onto your instance to fix the issue.

For more details see this ticket: CONF-28415

Thanks Mark - that did the trick! Greatly appreciate you folks providing fixes for earlier versions.

To eliminate one variable I upgraded the 4.1.3 site to 5.0.2, so both sites are now running the same version. That didn't help. I disabled Javascript caching in Chrome in case I had some old JS sitting around that was causing a problem, but that also had no effect. Both servers are running behind nginx but it's only a proxy and isn't configured for caching.

I discovered that I could get rid of the grab handles in IE by changing my style sheet. For a year or more I've had a CSS entry limiting the width of paragraphs. If I comment out that line the grab handles go away in the IE editor window. Chrome is unaffected by this change. It's not really a good solution because I still need to restrict line length for readability and I don't particularly want to use IE.

Hi David,

I'm having the same problem with Chrome. I haven't touched any JS setting nor site setting. I'm using 5.0.2. Tried on Safari, and things seem to work there.

Grant

Thanks Grant, I'm relieved to know I'm not the only one dealing with this. I installed Safari and it's working here too. Unfortunately I can't paste images with Safari, and that's one of the main reasons I'm using Confluence. I create a lot of documents that use screen shots, and to be able to paste images from the clipboard is essential to me.

Your suggestion inspired me to go back and try FireFox, which used to be my browser of choice. FF 21.0 appears to work perfectly. So that will do for now, but I'm not going to mark this as the answer because the original problem remains.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Confluence

Three common content challenges + how to manage them

An efficient enterprise content management system, or ECM, is a must-have for companies that create work online (cough   cough, all companies). If content calendars, marketing plans, and bu...

100 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you