Confluence can't find 2 users in Active Directory

We have been using Confluence since Sept 2013 with Microsoft Active Dirctory (Read Only, with Local Groups)

Last month two users could not log in to Confluence, they still can't.  When I logged in to Confluence as admin and went to Users, neither of the two users could be found by Confluence.  I have an LDAP browser and the two users' CNs are in the same directory, OU=Users, as the other users that regularly log into our Confluence. What could be causing this problem?  Our IT Active Directory person doesn't know why they aren't being found.

6 answers

Hi Nic,

Can you please verify if those users or the group that those users belong to have can use permissions in Confluence Admin > Global Permissions?

Apart from that, have you synchronized your external directory? 

Cheers,

Saleh

0 votes

Hi Nic, 

 

In addition, can you confirm if there isn't any duplicated username on Confluence Internal Directory or your Active Directory. 

If you try to synchronise the directory, these users are able to login? 

Lastly, can you check on logs while this users try to login on Confluence and let us know if some error message comes up?

 

Regards, 

Renato Rudnicki

 

We only have one user who is set with the Can Use permission, an administrator.  Everyone else is permitted through the group confluence-users which has the Can Use permission.  However the two users in question are not in the confluence-users group, because they cannot even be seen in the Users Section.  We only have the admin account in the Confluence Internal Directory.  Everyone else is through the MS Active Directory connection.  The two users cannot be found when I enter their names in the Users > Find User query.

Hi Renato,

Which logs are you referring to? The directory automatically syncs and is successfully syncing, the most recent message follows:

Last synchronised at 6/2/15 10:46 AM (took 451s).

Incremental synchronisation completed successfully.

HOwever the two users (who I see in the LDAP using other tools) are not found.  Using the advanced search on their email addresses I get "No users found", on my email address it finds me.  Their accounts in the LDAP (actually Microsoft Active Directory) are in the same OU=Users as is my account.  These users are not in the Internal directory, there are no users in the internal directory, just the admin and three system users.

Nic

 

 

Any further suggestions on this problem? We are facing the same issue

Try switch to full synchronization for AD user directory and execute full sync. Then you can switch back to incremental sync. This way works in my case.

I tried that but it didn’t help.  Just had our IT AD manager enter a system user account to access the AD and that resolved the problem.  Previously we were using anonymous access.  We still don’t know why anonymous didn’t work.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

333 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you