Confluence behind the nginx with SSL

I'd like to install confluence behind the nginx with ssl support, so my scheme is:

user -> nginx (https) -> tomcat (http)

Could you please show me correct nginx and tomcat configs for this purpose.

Thanks.

4 answers

1 vote

Hi Frankie,

in order to do that you need to perform the following operation :

- Set Confluence context path

Edit the following file <CONFLUENCE_INST_FOLDER>/conf/server.xml, locate "Context" and add the context path (eg ... path="/confluence" ...)

- Set the proxy to the Connector

Edit the following file <CONFLUENCE_INST_FOLDER>/conf/server.xml, and add your proxy

<Connector port="8090" maxHttpHeaderSize="8192"
maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" redirectPort="8443" acceptCount="100"
connectionTimeout="20000" disableUploadTimeout="true"
proxyName="www.example.com" proxyPort="80" />
- Setup you NGNIX
Set the following :
server {
ssl on;
ssl_certificate /path/to/self-ssl.crt;
ssl_certificate_key /path/to/self-ssl.key;
server_name theos.in;
location / {
....
...
}
}

- Update Confluence URL accordingly
Confluence Administration -> General Configuration

<Connector port="8090" maxHttpHeaderSize="8192"
maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" redirectPort="8443" acceptCount="100"
connectionTimeout="20000" disableUploadTimeout="true"
proxyName="www.example.com" proxyPort="80" />
Is it correct ? Because nginx (https) maybe proxyPort="443" and what about scheme param, or i have some misunderstanding you.

Also, i have the same bug as in https://jira.atlassian.com/browse/CONF-28564, does it related to correct tomcat/nginx configuration ?

proxy name and proxy port should be setup based on your nginx configuration.

proxyName=""www.example.com" proxyPort="443"

where www.example.comis the URL configured in your NGINX

Remember that after updating server.xml you need to restart confluence

0 vote

Remember that after updating server.xml you need to restart confluence

Hi @Fabio,

I have followed your instructions, but I recieve a 400 Error from NGINX stating that "The plain HTTP request was sent to HTTPS port".

Do you have any ideas?
Regards,
Karl

I am running in the same issue. Did you solved the problem?

Has anyone gotten this to work?

thanks

Hi Kenric, I have Nginx set up in front of one of my Confluence instances to terminate SSL and it's working beautifully. Do you have any specific questions regarding setting it up?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,901 views 27 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you