Confluence Synchrony Service problems

Hey gang,

 

We are getting some strange behaviour form the Synchrony service on Confluence 6.4.1. Specifically, we started to notice a large amount of TCP connections in TIME_WAIT state. Up to 40k at some times.

Dumping the connections I notice that the synchrony service is constantly sending a [3000,"Go away!"] message to every connection it gets.

Here's a capture of one of these such sessions. There are about 20 a second.

We proxy Confluence behind Apache and have the configuration directives setup as recommended in the documentation.

POST /synchrony-proxy/sockjs/v1/491/5ku54cb5/xhr?t=1507934759990 HTTP/1.1
Host: <hidden>
Origin: <hidden>
Cookie: JSESSIONID=76DAF8D27D8F865DA9DAD2A1ED8C3647; mywork.tab.tasks=false; doc-sidebar=300px; crowd.token_key=<hidden>; _ga=GA1.2.1113231744.1503434505
Accept: */*
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38
Accept-Language: en-ca
Referer: https://<hidden>/pages/resumedraft.action?draftId=73892450&draftShareId=38692875-f8f2-4920-8326-2c60efdcb543
Accept-Encoding: gzip, deflate
X-Forwarded-For: 10.3.6.146
X-Forwarded-Host: <hidden>
X-Forwarded-Server: <hidden>
Connection: Keep-Alive
Content-Length: 0

HTTP/1.0 200 OK
Cache-Control: no-store, no-cache, must-revalidate, max-age=0
Content-Type: application/javascript; charset=UTF-8
Set-Cookie: JSESSIONID=76DAF8D27D8F865DA9DAD2A1ED8C3647; path=/
Access-Control-Allow-Origin: https://<hidden>
Access-Control-Allow-Credentials: true

c[3000,"Go away!"]

2 answers

Check for errors in the atlassian-synchrony.log in the home directory. Or is the above capture from there?

Did you find out more?  I get this Go Away response on the web socket and the collaborative editing doesn't work.

I have not seen anything meaningful in the atlassian-synchrony.log file. A couple lines of debug maybe regarding and event create.

Hi Jeremy,

 

We proxy Confluence behind Apache also and see a lot of time_waits (~15k) once we enable Collaborative editing. We get performance issues (confluence will hang) when Collaborative editing is turned on. Once it is turned off, everything runs smoothly.

Do you experience any performance issues with your setup using Collaborative editing?

Yes, I followed the guide and everything looks to be in place.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

396 views 17 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you