Confluence SharePoint Connector and no-index

Hi all,

A customer of ours want to be able to search a Confluence instance from SharePoint, to which end we have found https://confluence.atlassian.com/display/SPCON/Confluence+SharePoint+Connector+Home .

So far, however, we either get very few results when attempting to crawl, or we hit an error stating that the meta-tag no-index prevented the crawl.

Now, we *have* specified a valid Confluence user, and we have *not* employed any custom robots.txt, but for the life of me, I cannot find a place to allow search engines (or SharePoint specifically) to crawl the instance.

The instance is in "private" mode, which should be a non-issue since we specify a user account.

Any and all help will be much appreciated.

1 answer

1 accepted

This widget could not be displayed.

By way of Atlassian Support, I discovered that our client was trying to set up a connection for Fast Search, which isn't supported after v. 1.0 of the connector.

The solution is to set up the system for Federated Search as per documentation.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

360 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you