Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,556
Community Members
 
Community Events
165
Community Groups

Confluence Server to Cloud Migration Tool Error

Server: 6.2.3

 

Installation of Tool Successful. 

Upon opening tool presented with an error.

 

Cause: 

org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getInitialState' in class com.atlassian.migration.agent.web.AppAction threw exception com.atlassian.util.concurrent.LazyReference$InitializationException: org.hibernate.exception.SQLGrammarException: Unable to build DatabaseInformation at /templates/app.vm[line 21, column 44]
    at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute(ASTIdentifier.java:223)

caused by: com.atlassian.util.concurrent.LazyReference$InitializationException: org.hibernate.exception.SQLGrammarException: Unable to build DatabaseInformation
    at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:149)

caused by: org.hibernate.exception.SQLGrammarException: Unable to build DatabaseInformation
    at org.hibernate.exception.internal.SQLStateConversionDelegate.convert(SQLStateConversionDelegate.java:103)

caused by: org.postgresql.util.PSQLException: The column name start_value was not found in this ResultSet.
    at org.postgresql.jdbc.PgResultSet.findColumn(PgResultSet.java:2589)

1 answer

1 vote

Hi @PulseI

Are you running CCMA on a H2 database? This isn't recommended and you should be doing the testing and production migration on an external database like PostgreSQL.

Regards,
James.

No. Here is our DB setup. 

Screen Shot 2022-05-20 at 3.07.11 pm.png

What version of Confluence are you running? If you have version 8.4.20 of PostgreSQL then that's not going to work.

The minimum version of Confluence that runs Confluence Cloud Migration Assistant is 5.10.0, and it has a minimum version of PostgreSQL of 9.2

See

Please upgrade your database to the minimum supported version for your version of Confluence and try again.

James.

Will do, thanks for your help. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

208 views 1 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you