Confluence Command Line - restoreExport Not Working

I am attempting to use the restoreExport command from the Confluence command line client, but I keep receiving an error that says Could not find indication of a successful start of import processing.

When I run the batch file with the -v option, this is what I get back:

C:\Confluence_CLI_Jarvis>confluence.bat -a restoreExport -f export.zip -v

Server address: http://servername:8090/rpc/soap-axis/confluenceservice-v1
Successful login to: http://servername:8090/rpc/soap-axis/confluenceservice-v1
by user: username. Token is Im58Fxwa1H
URL requested: http://servername:8090/admin/restore-local-file.action?os_userna
me=username&os_password=***&buildIndex=true&localFileName=DI1025_export.zip
Request type: GET
Content type: application/url_encoded
Response code: 200, message: OK, url: http://servername:8090/authenticate.actio
n;jsessionid=9C544173125941CE90C42B59BB687C30?destination=/admin/restore-local-f
ile.action?os_username=username&os_password=***&buildIndex=true&localFileName=DI10
25_export.zip
Start of response data: C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict
.dtd"><html><head>    <title>Adminis

Remote error: Could not find indication of a successful start of import processi
ng. Use -v to see some response data.
org.swift.common.cli.AbstractRemoteClient$RemoteRestException: Could not find in
dication of a successful start of import processing. Use -v to see some response
 data.
        at org.swift.confluence.cli.ConfluenceRestClient.parseResultData(Conflue
nceRestClient.java:167)
        at org.swift.confluence.cli.ConfluenceRestClient.restRequest(ConfluenceR
estClient.java:282)
        at org.swift.confluence.cli.ConfluenceClient.restoreExport(ConfluenceCli
ent.java:3952)
        at org.swift.confluence.cli.ConfluenceClient.handleRequest(ConfluenceCli
ent.java:665)
        at org.swift.common.cli.AbstractRemoteClient.process(AbstractRemoteClien
t.java:118)
        at org.swift.common.cli.CliClient.doWork(CliClient.java:302)
        at org.swift.confluence.cli.ConfluenceClient.main(ConfluenceClient.java:
132)
Im58Fxwa1H logged out.

I know it's not an authentication issue or an issue with the API not being activated, as I've been successfully exporting and deleting spaces via the command line.

(I should also mention that I have tried this with both version 2.6 and the 2.7 snapshot for the command line client.)

Edit: I'm using Confluence 4.2.12.

1 answer

1 accepted

0 votes
Accepted answer

Open an issue.

CSOAP-155 was opened - Secure administrator sessions must be disabled for this action to work.

I did so after I'd already posted this question. Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

965 views 14 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you