Confluence: Can't check base URL

Hello.. I'm getting an error in Confluence that says "Can't check your base URL: There may be an issue with your proxy configuration". Also, when I try to set up an Application Link from Jira to Confluence, I get the error "Invalid OATH Signature".

Here's the connector from the Confluence's server.xml file:

<Connector port="8090"
maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"
enableLookups="false"
maxHttpHeaderSize="8192"
debug="0"
protocol="org.apache.coyote.http11.Http11NioProtocol"
redirectPort="8443"
acceptCount="100"
URIEncoding="UTF-8"
disableUploadTimeout="true"
secure="true"
scheme="https"
proxyname="myURL.myDomain.com"
proxyport="443"/>

 

I've tried different variations in this file, but nothing's worked so far. Has anyone seen this issue before?

 

Thanks

3 answers

1 accepted

Accepted Answer
0 votes

The only way I can get the popup to go away is if I put the following as the Server base URL:

https://myURL.myDomain.com:80

But, that can't be right, can it?

Thanks

Ann Worley Atlassian Team Oct 26, 2017

I have a hunch I would like you to try. I would test it first but I don't have a test environment up with SSL terminated at the proxy.

Since you are using SSL (https) your base URL certainly shouldn't have port 80 appended to it. 

I noticed the proxyName and proxyPort in your server.xml are not camel cased but are all lower case. Since you had the freedom to rebuild the system I am hoping you can change the casing in the file and restart your instance without inconveniencing too many users:

proxyName="myURL.myDomain.com"
proxyPort="443"/>

I look forward to hearing the result.

Hi Ann, very sorry for the confusion -- I use lowercase everywhere, in the server.xml and the Server Base URL settings. The camel case is a force of habit, but this is how my configurations look like:

proxyName="myurl.mydomain.com"

Server Base Url = https://myurl.mydomain.com

One of the help articles I read said case does matter, so I made sure I was using lower case everywhere

Thanks

Ann Worley Atlassian Team Oct 26, 2017

Are you sure you are using the proper camel case in the server.xml? I ask because the snippet you posted uses all lower case for proxyPort and proxyName:

Here's the connector from the Confluence's server.xml file:
<Connector port="8090"
maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"
enableLookups="false"
maxHttpHeaderSize="8192"
debug="0"
protocol="org.apache.coyote.http11.Http11NioProtocol"
redirectPort="8443"
acceptCount="100"
URIEncoding="UTF-8"
disableUploadTimeout="true"
secure="true"
scheme="https"
proxyname="myURL.myDomain.com"
proxyport="443"/>

I've edited it below to reflect the case sensitivity that I have right now. Note, proxyname is all lowercase. Should the Protocol be in all lower case?


<Connector port="8090"

maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"
enableLookups="false"
maxHttpHeaderSize="8192"
debug="0"
protocol="org.apache.coyote.http11.Http11NioProtocol"
redirectPort="8443"
acceptCount="100"
URIEncoding="UTF-8"
disableUploadTimeout="true"
secure="true"
scheme="https"
proxyname="myurl.mydomain.com"
proxyport="443"/>

 Thanks

Ann Worley Atlassian Team Oct 26, 2017

In the connector directive of the server.xml, please change:

proxyname 

to

proxyName

and

proxyport 

to

proxyPort

Please restart Confluence to pick up the changes.

I have my fingers crossed - looking forward to hearing the result.

0 votes

Hi Sameer,

We have a document on this very issue with a few suggestions:

Can't check base URL warning in Confluence 6.1 or later

If you're running 6.1 or later you could try the solutions there and let us know if you still have any trouble.

Kind Regards,
Shannon

Hi Shannon, that's the document I've been using but still no luck. I just blew away the entire Confluence setup and re-installed. Now, I'm at the same point with the same error message. I've made the changes described in that help document again, but still the same issue.

I'm running behind an F5 load balancer and the encryption terminates at the LB, if this helps..

 

Thanks

Yes, that was it! I was looking at the value, not the parameter. Thanks so much! We've spent so much time and didn't think to look at the case on the attribute. The application link to Jira works, too!

Thanks again!

Ann Worley Atlassian Team Oct 26, 2017

I am so happy to hear it! Have a great rest of your day!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

331 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you