Confluence 5 Sidebar missing

Hello,

we get the same exception as described here:

https://answers.atlassian.com/questions/187975/why-is-the-sidebar-missing-in-my-confluence-5-instance

In our Confluence 5.1.5 installation (upgraded from 4.3.6) the confluence 5 sidebar disappears when we access a public space as "anonymous" user.

If we login with a wiki user the sidebar of this space appears without problems.

If I change the theme of this space to "Documentation Theme" the sidebar appears for the anonymous user also.

Changing the theme of this space back to the Confluence default theme makes the sidebar disappear again for the anonymous user and throws an excption in getHtml [plugin.descriptor.web.ConfluenceWebInterfaceManager]

You can try it yourself:

https://wiki.aau.at/display/~ghoch/Gerald+Hochegger+Home

gives:

2013-08-05 10:55:19,114 ERROR [TP-Processor12] [plugin.descriptor.web.ConfluenceWebInterfaceManager] getHtml Failed to render web panel: com.atlassian.plugin.web.descriptors.DefaultWebPanelModuleDescriptor$ContextAwareWebPanel@7757ada8
-- url: /display/~ghoch/Gerald+Hochegger+Home | page: 12058652 | userName: anonymous | referer: https://wiki.aau.at/spacedirectory/view.action | action: viewpage

java.lang.NullPointerException
at com.atlassian.confluence.plugins.ia.impl.DefaultSpaceBeanFactory.createSpaceBean(DefaultSpaceBeanFactory.java:36)
at com.atlassian.confluence.plugins.ia.ui.DefaultSoySidebarContextProvider.populateWithMainSidebarData(DefaultSoySidebarContextProvider.java:131)
at com.atlassian.confluence.plugins.ia.ui.DefaultSoySidebarContextProvider.getContextMap(DefaultSoySidebarContextProvider.java:75)


We are using postgres for our datebase - the suggested query from the answer above above gives:

select BANDANAVALUE from BANDANA where BANDANAKEY = 'plugin.manager.state.Map';

<map>
<entry>
<string>com.atlassian.confluence.whatsnew:show-whats-new-flag</string>
<boolean>true</boolean>
</entry>
<entry>
<string>com.atlassian.confluence.plugins.confluence-software-blueprints:requirements-item</string>
<boolean>false</boolean>
</entry>
<entry>
<string>com.mxgraph.confluence.plugins.diagramly:diagramly-blueprint-page</string>
<boolean>false</boolean>
</entry>
<entry>
<string>com.atlassian.confluence.whatsnew</string>
<boolean>false</boolean>
</entry>
<entry>
<string>confluence.sections.attachments:edit</string>
<boolean>false</boolean>
</entry>
<entry>
<string>com.atlassian.confluence.plugins.confluence-paste:autoconvert-jira</string>
<boolean>false</boolean>
</entry>
<entry>
<string>confluence.sections.attachments</string>
<boolean>false</boolean>
</entry>
<entry>
<string>com.atlassian.confluence.extra.officeconnector:editattachmentinworditempathauth</string>
<boolean>false</boolean>
</entry>
<entry>
<string>confluence.sections.attachments:remove-version</string>
<boolean>false</boolean>
</entry>
<entry>
<string>com.atlassian.confluence.plugins.confluence-business-blueprints:file-list-item</string>
<boolean>false</boolean>
</entry>
<entry>
<string>com.atlassian.confluence.extra.officeconnector:editattachmentinworditem</string>
<boolean>false</boolean>
</entry>
<entry>
<string>confluence.sections.attachments:remove</string>
<boolean>false</boolean>
</entry>
<entry>
<string>com.mxgraph.confluence.plugins.diagramly:diagramly-blueprint-item</string>
<boolean>false</boolean>
</entry>
</map>

Please help me fix this - we need a working sidebar for public personal spaces.

Thanks,

Gerald

4 answers

1 accepted

1 vote
Accepted answer

Hi Gerald,

You're right! This is a bug.

I have raised a bug ticket to alert our developer for you https://jira.atlassian.com/browse/CONF-30321. Please vote and watch this bug ticket fot the lastest update.

You can refer to our Policy if you wish to know more about Atlassian bug fixing procedure.

Cheers,
Jing Hwa

0 votes

HI there,

Judging from the symptom, this should be related to some customisation that are made in the global template. Please create a fresh space and try the following:

  1. Navigate to Confluence Admin >> Plugins and Enable Safe Mode.
  2. Navigate to Confluence Admin >> Layouts and reset all custom layouts to default (but make sure to make a backup of the custom layouts first!, by editing the layout, and copy pasting it to a text editor, to avoid losing your customizations)
  3. Navigate to Confluence Admin >> Custom HTML, and make sure that you do not have any Custom HTML added to Confluence. If there are, edit and save them into a text editor as a backup, and remove all of them.
  4. Navigate to Confluence Admin >> Stylesheet, save all custom CSS into a text editor and remove all of them.

Try to check the page after each step. This will help us to identify the root cause of this issue.

Kind Regards,
Jing Hwa 

Thanks for your suggestions - what I've done so far:

Checked and removed the customizations - there was indeed a Custom HTML "at end of the BODY"

I've not enabled "Safe Mode" for the addons.

The failing space from above
https://wiki.aau.at/display/~ghoch/Gerald+Hochegger+Home is still failing.

Then I created a new space with the default theme:

https://wiki.aau.at/display/testghoch/Testspace+Ghoch+Startseite

In this new space the sidebar appears correctly !

So it seems the "Custom HTML" is still somehow included in the failing space.

Can I remove the "Custom HTML" from an existing space ?

Should I recreate the failing space ?

Greetings,

Gerald

Seem like there is some customisation in the space itself. Please try the following in the affected space:

  1. Navigate Space Tool>>Look and Feel>>Layout then reset all the layout to default
  2. Navigate to Confluence Admin >> Stylesheet, save all custom CSS into a text editor and remove all of them.

Again, try to check the page after each step.

Apply documentation theme.

Yes changing the space theme to documentation theme makes the sidebar visible again - I've already tried this - but the default theme looks better.

Answering Jing Hwa:

  • I've checked Space Layout and Global Stylesheet - there are no customizations
  • I've even enabled Safe Mode for a short time

But nothing makes the sidebar of my personal space visible.

Furthermore I tried to verify this on two other (10 user) Confluence Wikis - same result !

So this is very likely a bug - how to reproduce:

  • create a personal space with the default theme and create a testpage inside
  • edit permissions and give anonymous "view" right
  • give anonymous the global "use wiki" right

Then logout our use another browser to view the just created personal space as anonymous. On all my three conflunece Wikis I get the same failure - when using the default theme a public personal space has no sidebar.

Otherwise a normal (not personal) public space doesn't have this problem - only public personal spaces suffer from the disapearing siderbar - at least on my three Wikis (5.1.4, 5.1.5)

Greetings,

Gerald

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,032 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you