Confluence 5.4.3 adding comments to pages

Is anyone having issues adding comments to pages in Confluence? We use IE 8, which I know sucks, but is by the unfortunate company policy. We also use Google Chrome.

I am experiencing issues in both browsers. In Chrome, we do not see the add comment button at the bottom of the page, and cannot click in the comment box to type anything. In IE, we see the add comment button, but cannot type in the editor once it comes up in the comment area.

I have tried downloading the current version of Firefox, but it too has issues. I have tried disabling our plugins, with no luck in fixing. I have put Confluence into safe mode, and that does not fix it.

I have full administrator rights, and am having the issue along with all other users. I can however type (m), and we get the comment editor in the comment area. Unfortunately, we cannot type in that editor though. So I click save, which opens another editor screen because it cannot save an empty comment. In this secondary editor screen, we can type our comments and post them. This is a huge hassle. We were able to do this prior to upgrading to 5.4.3.

Does anyone have any suggestions?

Thanks.

5 answers

1 accepted

So we fixed the encoding of the database, etc. Right off that did not fix our commenting issue. Then we looked at the plugins again. I disabled all of them again, and that did not fix it. I proceeded to uninstall each one by one, and I found a plugin that was causing this issue. Obviously, disabling them did not help it or we were a victim of caching. Thanks for everyone's help on this.

0 vote

Do you have any custom layout, html or stylesheet changes? They might have triggered such problem.

There are not any custom layout, html or stylesheet changes.

Is your IE running in compatibility mode?

Which theme are you using?

IE is not running in compatibility mode. Please note that I have tried this in Google Chrome and Firefox as well.

We are using the default theme.

Ok, next question...

Do you have any web application firewalls or similar security features in use? Do you have some 40x codes on some of your requests? Use Chrome and view the network traffic to figure this out.

We think this is related to the encoding. Database is set to latin1.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

450 views 21 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you