Confluence 5.1.3 problem - Unable to find template renderer to handle file extension .soy

Hi, I'm just trying to use Confluence in my department. I downloaded the trial version 5.1.3 to get to know some features of this newest version of Confluence. I installed the software in my desktop following the online installation guide in this site.

But when I start and access Confluence, I always see the error "$soyTemplateRendererHelper.getRenderedTemplateHtml("com.atlassian.auiplugin:aui-experimental-soy-templates", "aui.page.header.soy", $templateParameters) " on the top and "Error formatting macro: recently-updated-dashboard: com.atlassian.confluence.renderer.template.TemplateRenderingException: Unable to find template renderer to handle file extension .soy" on the right side of the page.

I searched this using google and found there were several people who had the same issues. Someone said that the issue was resolved after restarting the Confluence. But I tried this several times and nothing happened for this issue.

We are planning to use this new version of Confluence but I'm not sure if we will still have the same issue on the server. Could you give any suggestions about this problem? Thank you!

4 answers

1 accepted

Accepted Answer
3 votes
Ruchi Tandon Atlassian Team Jun 16, 2013

Hey Xing,

After researching further, I figured out that the problem could be caused due to the fact that not all modules of the Soy plugin are enabled. Please refer to this KB article : Comment Box Disappears: $soyTemplateRendererHelper.getRenderedTemplateHtml and verify that all modules are enabled and then restart the instance. Hopefully that should resolve the problem in this case.

Possibly Atlassian Soy Templates Plugin and/or Confluence Soy Templates Support Plugin got disabled. To check on this, navigate to Confluence Admin > Manage Add-Ons and ensure that the System Plugins and all of their modules are enabled.

PS: Are you using the bundled HSQLDB or connecting Confluence with an external database? If you are using an external database e.g. MySQL AND you failed to enable one or both of the mentioned plugins, you can try to manually enable it through the database following this documentation.

Hi, Hanis, thank you for your reply. But I couldn't reach the Confluence Admin > Manage Add-Ons because the page is not displayed properly. There is no link for it on the page.

BTW, I just want to have a try first for the installation and use for the newest version Confluence. Our department wants to upgrade the very olde version Confluence used now. Therefore, I use the embedded HSQLDB as the database.

0 votes
Ruchi Tandon Atlassian Team Jun 13, 2013

Hey Xing,

Usually, such error can be solved by clearing plugin cache or increasing the time it takes for the plugins to wait as mentioned in the Step 2 of the resolution in this KB.

I hope it helps in your case.

Thanks for all your help. I tried the solution "manually enable the plugin through the database" following the instruction you provided. But it looks not working. I uninstalled the version of 5.1.3 and tried version 5.0. The same problem is still existing. After that, I uninstalled the version 5.0 and tried version 4.1.10 and it works fine this time. Just now, I wanted to have another try for the newest version so I uninstalled the version 4.1.10 and installed the version 5.1.3 again. Now the newest version works. I have no idea what happens. But now I can have a try for the trial version of 5.1.3. Thank you all for your kind help.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

319 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you