• Community
  • Products
  • Confluence
  • Questions
  • Confluence 4.2 Upgrade: Adaptivist Plugin - WARN addingService PLM Jar file was not signed by PLM Root Certificate, License Service will be unavailabl

Confluence 4.2 Upgrade: Adaptivist Plugin - WARN addingService PLM Jar file was not signed by PLM Root Certificate, License Service will be unavailabl

Hi

I'm having issues upgrading our production confluence installation from version 4.1.9 to version 4.2.0. I've attempted this twice and both times I've been forced to roll back the upgrade.

The Upgrade in its self is sucessful and i can log into confluence, however when i request a page i get a browser error indicating that /pages/viewpage.vm cannot be found. In the application log i see the following error:

2012-04-11 13:31:21,738 WARN [http-8280-5] [adaptavist.plm.service.VerificationServiceTrackerCustomizer] addingService PLM Jar file was not signed by PLM Root Certificate, License Service will be unavailable
-- referer: http://confluence.us.sagepub.org/dashboard.action | url: /display/SPSI/Alfresco+Installation+on+Ubuntu+10.4 | userName: Fowler | action: viewpage | page: 44237099

2012-04-11 13:31:22,190 ERROR [http-8280-5] [opensymphony.webwork.dispatcher.VelocityResult] doExecute Unable to render Velocity Template, '/pages/viewpage.vm'
-- referer: http://confluence.us.sagepub.org/dashboard.action | url: /display/SPSI/Alfresco+Installation+on+Ubuntu+10.4 | userName: Fowler | action: viewpage | page: 44237099
org.apache.velocity.exception.ResourceNotFoundException: Unable to find resource '/pages/viewpage.vm'
...
...

I have macro's (templates) on all my pages that use the adaptivist free plugins, activiated by the Plugin Licensing Manager (PLM). My suspicion is that the WARN statement above means that when the PLM License Service is unavailable, that all the Adaptivis plugins also fail, and ultimately causes the ERROR i see in the logs.I have attached the full log of a fresh restart for reference.

Can I ask - has anyone else expeienced this issue and found a resolve before i talk to the Adaptivist community??

Many thanks.

Gavin. (atlassian-confluence.log)

1 answer

1 accepted

This widget could not be displayed.

The response from Adaptivist reads:

Thanks for your question. None of our plugins are currently compatible with Confluence 4.2. We'd recommend removing incompatible plugins prior to upgrade or not upgrading until the required plugins have been upgraded.

Adaptavist have updated the Page Information Plugin to version 2.0.1. this update corrected my issues with the PLM and allowed me to successfully upgrade to confluence to version 4.2.0.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

569 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you