Confluence 4.2 Unmigratedwikicontent.action

Hi all,

i have upgraded confluence from 3.5 to 4.2. some user macros are wrapted as unmigrated-inline-wiki-markup.

when i force to upgrade through admin/unmigratedwikicontent.action its showing 16 pages with macros that are not yet confluence 4+ compatible.

when i have update content its still showing 16 pages with macros that are not yet confluence 4+ compatible.

Thanks,

Tousif shaikh.

2 answers

1 accepted

3 votes
Answer accepted

Hi Tousif,

One of the most common reasons that you will be facing this issue is that some of your plugins have not been updated to be compatible with Confluence v4.x and so the macros emvedded in the page are unknown to the content migrator. So one thing you can check is whether all your plugins are upto date.

Another common cause of migration failure is encoding issues, (especially the database), so you should also check to see whether all the components of your system are all using the preferred UTF-8 encoding scheme by following the instructions below:

*Confluence encoding:* https://confluence.atlassian.com/display/DOC/Configuring+Character+Encoding
*Tomcat encoding:* https://confluence.atlassian.com/display/DOC/Configuring+Tomcat%27s+URI+encoding
*Database encoding:* https://confluence.atlassian.com/display/DOC/Configuring+Database+Character+Encoding

If neither of those options resolves your issue then you should open a ticket with Support, including a copy of your logs following an attempt to perform the content migration so that we can get a better idea of why it is failing.

All the best,
John

Hi John,

we also have a similar problem, unmigratedwikicontent.action page shows me 318 pages that have macros seeming not beeing compatible with Confluence 4.3.x.

Is there a way what pages exactly are affected so I can have a look into these pages directly? I did not find any incompatible macros so far, all Plugins are up to date.

Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

983 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you