Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,038
Community Members
 
Community Events
176
Community Groups

Confiforms - Trying to initiate a Rest GET/POST to confiforms but account may be locked

Edited

This question is a bit convoluted so please bear with me.

We have a Confluence site and we have a couple of service accounts (we'll call them "account1" and "account2") we use to automate updating Confiforms forms. Basically one system uses account1 and another system uses account2, both for updating various Confiforms forms on the Confluence site.

I've been working on a script to automate posting certain info to a specific Confiforms form and I've been using account1 as authentication when testing my script. The script gets/posts info to the forms via a Rest method. It was working fine for a while then without my knowledge someone messed up changing the password for account1, at which point my script of course stopped working.

They've since corrected the account1 password and I've gotten the new one, but the script is still failing--I tried it with account2 and it works (both accounts were changed to the same password at the same time). I know the account1 password is correct, because we use that account for other things and those are all working.

The accounts authenticate via another auth provider and I know account1 isn't locked out there because, again, it's working for other processes we use it for (they stopped working initially when the other guy messed up the password, but it's working again now that he fixed it). I can also log into the auth provider with the username/password.

Does Confluence/confiforms "lock out" or block accounts after a number of failed connection attempts? If so, how would I reset/unlock it so I can resume using account1? Otherwise, if anyone has any other ideas as to what could be going wrong I'm open to them.

Thanks!

1 answer

1 accepted

0 votes
Answer accepted

Another team member mentioned that sometimes Confluence requires these accounts to enter a CAPTCHA upon login--I tried logging into Confluence with the account and it prompted a CAPTCHA. After entering it, I got in and the script started working again.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events