It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Colllaborative Editing Proxy not working

Im using Confluence since a few months. After a server restart a few days ago, im not able to edit anything anymore.

It still shows the message that he cannot reac the server.

 

I'm using ubuntu as base Ubuntu 17.04 with Apache as reverse Proxy.

Today, i've added the Websocket config in Apache but afterwards the editor shows the message "The site needs more time to load..."-

 

Following my Apache and Confluence Config.

 

Apache with enabled modes:

 

confluence.company.de is the public Domain therefore and thf-apcfue01 the servers hostname.

 

<VirtualHost *:80>
ServerName confluence.company.tlc

ProxyRequests Off
ProxyVia Off


ProxyPreserveHost On



<Proxy *>
Require all granted
</Proxy>


ProxyPass /synchrony http://thf-apcfue01.company.de:8091/synchrony
<Location /synchrony>
Require all granted
RewriteEngine on
RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
RewriteRule .* ws://thf-apcfue01.company.de:8091%{REQUEST_URI} [P]
</Location>



ProxyPass / http://thf-apcfue01.company.de:8090/
ProxyPassReverse / http://thf-apcfue01.company.de:8090/
</VirtualHost>

 server.xml

<Server port="8000" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<Connector port="8090" maxHttpHeaderSize="8192"
maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" redirectPort="8443" acceptCount="100"
connectionTimeout="20000" disableUploadTimeout="true"
proxyName="confluence.company.de" proxyPort="80" />

<Engine name="Standalone" defaultHost="localhost" debug="0">

<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false" startStopThreads="4">
<Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
<!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties -->
<Manager pathname="" />
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
</Context>

<Context path="${confluence.context.path}/synchrony-proxy" docBase="../synchrony-proxy" debug="0" reloadable="false" useHttpOnly="true">
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
</Context>
</Host>

</Engine>

 

1 answer

0 votes
Jonathan Smith Community Leader Apr 25, 2018

***This worked for us; Not sure if it is your situation.***

March 30th we upgraded to 6.6.1 ---after we couldn't edit pages. Turning off collaborative editing allowed us to edit pages again however we lost the 'co authoring' piece.


My sys admin resolved after looking into the following content. https://confluence.atlassian.com/confkb/confluence-throws-the-editor-didn-t-load-this-time-error-when-trying-to-edit-a-page-840796639.html

I believe he modified this setting in confluence.cfg.xml

<property name="synchrony.encryption.disabled">true</property>
    <property name="synchrony.proxy.enabled">true</property>

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

Introducing Confluence Cloud and Jira Software Cloud Premium

Wherever you are in your team’s journey , our goal is to support your big ambitions. We’re a cloud-first company with the mission of unleashing the potential of every team, and to address the range ...

640 views 4 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you