Character broken in confluence.

Help Me ~~

Fonts/Characters are wrong rendered in my confluence.(reference following images)

The confluence is installed on CentOS6.

4 answers

1 accepted

This widget could not be displayed.
Joe Wai Tye Atlassian Team Nov 12, 2012

Hi Perry,

What version of Confluence are you using? I asked around, and this might be a known bug of Confluence. Please tell me what version of Confluence you are using, so that I can check with the bug report to see if it is related

Cheers,

Joe

Hi Joe,

The version is 4.2.8.

Thank you so much!

Cheers,

Perry

Joe Wai Tye Atlassian Team Nov 15, 2012

Hi Perry,

May I know if the characters are still broken even after you save the edit? If it's not broken after you save it, then I suspect that you are facing this bug : https://jira.atlassian.com/browse/CONF-23595

Cheers,

Joe

Yes, its the same bug -- in edit mode the Macro Title's characters are broken.

If saved the edit, all the characters are alright. In other words, if the characters be rendered with normal HTML page are alright. If the characters be rendered in image or flash are broken(The MacroTitle is a image in edit mode).

Refer to the first picture.

The second picture is about the bug in ppt, like the following bugs:

https://jira.atlassian.com/browse/CONF-25408

https://jira.atlassian.com/browse/CONF-16712

Joe Wai Tye Atlassian Team Nov 18, 2012

Hi Perry,

If it only occurs when you are editing, then it is indeed the bug which I mentioned. In that case, it is supposed to be fixed in Confluence 4.3. I would recommend that you upgrade to that version as soon as possible in order to fix this bug.

As for the other 2 bugs, it seems that they are set as Major and Critical, hence they should be fixed soon. However, I'm not able to provide you with a solid date, as this is in the hands of the developers.

I would recommend that you watch and comment on the bug tickets to give your opinion and receive further updates.


Cheers,

Joe

Hi, Joe

Thanks for your patience!

But I'm very sorry to tell you that I upgraded the version to 4.3.2 already, but it's still not working...

T_T, I totally crashed...

I decide to close this question and follow the bug issues.

Thanks again,

Cheers,

Perry :)

This widget could not be displayed.
Joe Wai Tye Atlassian Team Nov 12, 2012

Hi Perry,

Could you check the encoding of your database and see whether or not it is set to UTF-8? I suspect that this is caused by the encoding. Please also check this article : https://confluence.atlassian.com/display/DOC/Troubleshooting+Character+Encodings

Cheers,

Joe

Hi Joe,

Thanks for helping me. But this answer cann't resolve my problem.

I checked my settings, the encoding is alright. It's fine when displayed in HTML pages.

But bad happens when rendering with ".ppt Macro" (or shown in MacroEditor's TitleBar), like the attachment imge.

Some people said that its caused by "missing Font files", I think that is the problem, but I don't know how to fix it.

Joe Wai Tye Atlassian Team Nov 12, 2012

So it only happens in the Macros? Hmm, I'm not quite sure about the missing Font files...but when using the usual features (typing them in the page, etc) it shows up fine?

Yes, in normal page its fine.

Peter Koczan Atlassian Team Nov 12, 2012

Hey, Did you also check the Tomcat URI encoding as of this article?

This widget could not be displayed.
Peter Koczan Atlassian Team Nov 12, 2012

Hi,

Have you also checked the Tomcat URI encoding according to this article?

Cheers,

Peter

Thanks Peter,

I had checked the Tomcat URI encoding, It's already be set as the article correctly.

Cheers,

Perry

This widget could not be displayed.

Are you using Mysql? Its implementation of UTF-8 is not comprehensive, apparently 6byte UTF-8 chars are not supported. If you're using Postgres, you can rule out the database at least.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

470 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you