Can't use Zen theme with my space

I choose the Zen theme for one of my spaces and I get the following error:

Error occurred during template rendering: Invocation of method 'cssBundle' in class com.zenfoundation.theme.ZenTheme threw exception com.atlassian.core.exception.InfrastructureException: Error occurred rendering template content at theme/html/macros.html[line 242, column 30]. Contact your administrator for assistance.

7 answers

1 accepted

The problem appears to be within the Breeze brand plugin. In order to fix the space, disable the Zen plugin. This will allow you to access the space. Switch the the theme to some other theme (I was left with documentation as the only unused one). Confirm that then switch back to global. This clears the Zen theme.

You can then re-enable the Zen plugin. At this point, I switched to Zen Intranet as the default plugin and changed the theme to Zen and it worked fine.

I should add that along the way I uninstalled the Zen lightning plugin. The brand plugin is still in place.

Can you confirm you installed the latest version of the plugin? This could be the reason for this issue.

I'm also not gettng an "update available" indication.

I'm at 5.2.8 for Zen Foundation, 1.0.3 for Intranet, and 1.0 for Lightning.

I'm also getting same error, does anyone know the solution? thanks

FWIW, I just was playing with yet another space with another Zen plugin and it broke again. I'm thinking that Zen is so utterly unreliable that I'll probably just toss it out altogehter.

0 vote
Ann Worley Atlassian Team Feb 01, 2014

Hi Jeffrey,

Maybe try Brikit support before tossing it out?

http://www.brikit.com/display/brikit/Welcome

Cheers,

Ann

I'm going to first fully upgrade Confluence to get it current then install Zen again. If that doesn't work, I'll try the support team. However, this is one of those if troubleshooting takes too much effort, the tool isn't worth the trouble.

Also, if we can't nail down an actual cause and get it fixed, but rather magically get it working again, I'm going to drop it. There was nothing odd about my installation, and I can't have a situation where if I change the look and feel on a space have it rendered completely inaccessible. Even the risk that it might happen is a bit much.

Well, uninstall Zen, upgrade Confluence to 5.4.2, reinstall Zen seems to fix things. I'll hold my breath for a while while I develop some custom themes on a test site. If it appears stable, I'll stick with it, as it makes brand development relatively straightforward.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,850 views 27 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you