Can't use Edit in Office in Confluence V4

I can't get this to work in IE, we're running Confluence V4.

When you click on the link Word or Excel start to open, but then I'm asked by WedbDav server to enter my user details and password. I do this, and the window closes, then re-opens with the same question.

I've done this few times and nothing happens, so I give up.

We're using HTTPS and running Windows 7.

I've had a look at the forum and there some info on this, but not addressing my specific problem. I can't believe that it's a problem with Confluence, as I'm sure Atlassian must have tested this quite thoroughly.

Cheers.

7 answers

1 accepted

I think we might have solved this. When you click on Edit in Office and the login box opens, it's (in our case at least) already got our NETWORK name already loaded.

But what it really wants is your wiki login details.

So instead of using what's already there, I entered my wiki name and password and it worked! I tested it to make sure I could add and save data, and that wasn't a problem.

It'd be great to know if this works for anyone else who has had this problem.

Cheers,

We had the same problem, and solved it the same way. its quite a pain in the behind if you ask me. (oh and you may see a similar problem creep up if you are using office 2010. I have a registry fix for that one if you need it)

Jo-Anne, thanks,a nd thanks for the warning about Office 2010.

This indeed can be confusing sometimes as to whether enter Confluence credential or your Windows credential. You need to enter Confluence credential instead as Mick said above. To avoid getting login prompt when dealing with Office Connector activity, you can enable "Authentication: Allow authentication tokens in the URL path" option in Office Connector configuration.

This is exactly the problem we had. Because it populated our network username, we thought it was those credentials. It would be helpful to have some of these instructions/guides in the documentation. But, am so glad for this forum and search :-) The wiki credentials are all we needed to resolve our problem. Thanks!

Hi Mick, there's been a recent thread about this - https://answers.atlassian.com/questions/31720/edit-in-office-link-is-not-working-in-confluence Not sure if anything in that thread is useful to you? Andrew.

I've recieved this from Andrew Frayling via email, but can't see it as an answer here.

Andrew, thanks and yes, I had seen the thread and a number of others but wasn't clear about what they were saying. Some seem to suggest that this has been fixed from a certain Confluence version, others suggest it's an MS thing and is still broken. It's definitely not working for us whatever the cause. :)

Cheers,

Andrew Frayling posted a new answer for

Can't use Edit in Office in Confluence V4

Hi Mick, there's been a recent thread about this - https://answers.atlassian.com/questions/31720/edit-in-office-link-is-not-working-in-confluence Not sure if anything in that thread is useful to you? Andrew.

If this answers your question, please accept it. If not, consider revising your question or requesting more detail in a comment.

Hi Mick,

even though this article ssems to be related to WebDAV folders you might try to alter the registry setting as described here:

http://confluence.atlassian.com/display/CONFKB/Unable+to+authenticate+while+mapping+a+WebDAV+client+network+drive+in+Microsoft+Windows

Cheers

By the way, it once happened to a customer that he had somehow exceeded the allowed number of false authentifications (while he was logged in, our guess is a problem with a card reader!) which prevented him from opening the documents. Resetting the authetifications and reestablishing the netwoirk connection did the trick...

Christian (and Andrew), thanks for this info. I've passed it on to our technical department.

if I get any more info from them on this I'll post it here.

Hi Mick,

Sorry. I posted in haste as the other thread was fresh in my mind and then re-read your question properly and noticed that you'd already searched this forum, so deleted my post as I figured you'd probably already read the other thread.

WebDAV client support in Windows is a bit tempremental, but hope some of the suggestions in the various threads provide a solution for you.

Andrew.

Andrew, I thought it was me! Thanks for the input anyway, it's always good when people take the time to try to help. Much better than the alternative. :)

We're new to Confluence, starting with 4.0 and ran into this too. Also running https: but on Windows XP. What we have found most helpful is to be sure and check "remember me" when you login to Confluence. That seems to store your wiki ID/pass and you shouldn't see repeated requests for authentication. Excel seems more temperamental than Word in this area; we've also counseled our users to launch Excel from their desktop before requesting to Edit in Office - -seems to help.

Claire,

thanks for that. I'll make a note of this in our admin space.

Cheers.

PS, I never log out of the wiki, so this shouldn't be a problem. :)

FYI - it still asks for credentials, regardless of your session state with the wiki. User logs in to wiki > navigates to a page that has the document > clicks on Edit in Office > they get a popup for their credentials, populated with their network username > you need to replace the username with your wiki username and input your wiki password.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

401 views 17 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you