Can't update higher than 5.3.2

Dear Gliffy Team,

i’m only able to install the older version 5.3.2 in confluence.

Any newer Version shows me, that an error occurred, and I should have a look into the logfiles.

Can’t find any error in my logfiles.

I uninstalled Gliffy, and tried to reinstall via Atlassian Marketplace - doesn’t work because of higher version.

Only manual reinstall of downloaded older version 5.3.2 did the job.

Is there no more update for us available because of special COMMERCIAL_ENTERPRISE -License?

Our Config:

Confluence 5.1.3

Universal Plugin Manager (v2.12.2)

Installing works only with gliffy-confluence-plugin-5.3.2.jar (Licence still stored in confluence, no action needed))

These installs didn’t work and showed a nonsaying error:

gliffy-confluence-plugin-5.4.1.obr

gliffy-confluence-plugin-5.4.jar

By the way: I found a Gliffy-Licence in my Atlassian-Login, but can’t apply that in my 5.3.2 Gliffy

Hopefully that helps you to give me a hint, how to move forward with my update task.

Kind regards,

one of your greatest fans

3 answers

1 accepted

Hi Daniel,

with one word: success!

In detail:

  1. I still had no entry about an error in catalina.out on my side...
  2. But i didn't mind, and tried your solution on my confluence server terminal as it couldn't break much:
    sudo nano /etc/mysql/my.cnf

    and changed the max_allowed_packet argument from 32M to 64M

    max_allowed_packet=64M

    I saved the file (STRG+X in nano)

  3. as mentioned in your second post i did also a mysql restart in my confluence server terminal
    sudo service mysql restart
  4. In confluence then as Admin i retriggered a "paid gliffy update", and
    this time it ran thru - Gliffy 5.4.1 on track - YEAH! Copying the licence from my.atlassian into it worked then as expected

so still have fun everyone, and thank you Daniel!

Andy

I am getting this error too. After clicking on update, I did a tail -f on the log file and it showed an error message.

2013-07-30 13:05:00,472 ERROR [pool-22-thread-4] [sf.hibernate.util.JDBCExceptionReporter] logExceptions Packet for query is too large (34647544 > 33554432). You can change this value on the server by setting the max_allowed_packet' variable.

I edited /etc/mysql/my.cnf and changed the max_allowed_packet. Save the file and upgrade which worked fine.

max_allowed_packet = 64M

I forgot to mention that I restarted mysql and then upgraded.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

381 views 21 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you