Can't edit the space overview page

I currently cannot edit the Overview page on any of my spaces in Confluence.
I can edit subpage of the spaces no problem.

When on the overview page, if I tap the e shortcut key nothing happens, and when I click the ... menu button where the Edit button would normally be located I nothing, like the shadow of a drop down menu but no content (the attached screenshot shows what I'm seeing).

screenshot.20161101-121546.png

When I do hit e or the menu on any of the sub-pages it works properly and lets me edit the pages and see the full menu including the Edit option.
Whatever the problem is it's restricted to the overview pages.

No new add-ons have been added recently, and I was able to edit these pages within the last week.
I have full admin access to all the spaces and none of these pages are restricted.

I have tried this in both FireFox, Internet Explorer and Edge and I'm seeing the same behaviour in both.

I recently deleted some unused spaces but that's the only significant change and I don't see how that would effect anything.

6 answers

As Patrick confirmed that it wasn't just me seeing this, I reported it to support.

They've responded that the Overview page is a new feature that's only available to some customers so far and it appears to be a problem with that, so they've deactivated it on my account.
So I'm back to the regular main page view, but I can edit the root pages again.

Thanks for the responses guys.

Colette

Hi Colette,

When you say the "Overview" page of your spaces, do you mean the home page of each space?

Assuming that's what you're referring to, there's no specific configuration item that will bulk prevent all home pages from being editable.  The most likely scenario is that another admin has changed the page restrictions to prevent people editing those pages.

Even as an administrator, you can be locked out from editing a page if someone changes the restrictions on the page.  When you prevent a user editing a page, it also removes their right to change the restrictions for the page.  Are you able to open the restrictions for any of these pages?

Hi Rob, yes I'm talking about the home page of each space.

I can't directly view the restrictions because I can't edit the page and can't view anything in the context menu, but if I go to the Space settings and look at the Permissions> Restricted Pages tab there are no pages at all listed there.

Also, if I couldn't edit the parent page, wouldn't that cascade to the child pages as well? I can edit and view and change the restrictions on the child pages within each space.

Hi Colette,

Based on what Patrick and you have said this looks likely to be a bug rather than a permission issue (when 2 people get the same thing that's normally a red flag).  Your best bet is to raise a support ticket and point them to this question so they can see it's not an isolated issue.

On a side note, View permissions cascade (i.e. if you can't view the parent then you can't view the children), but Edit permissions don't (so you can edit the children even if you can't edit the parent). Both View and Edit permissions inherit, so when you create a child page it will have the same View and Edit permissions as the parent. Hope that helps smile

If have the same issues. I can't edit the overview/homepages of any space. I have full admin rights within confluence. 

 

Any suggestions?

image2016-11-1 14:47:53.png

image2016-11-1 14:48:25.png

 

image2016-11-1 14:49:55.png

The general rule of thumb when multiple people get a weird problem is that the problem is either the browser or the application.

Colette was using Firefox, and there's an issue regarding the Page Properties Report macro throwing an error with the latest version of Firefox.  This may be another issue with the browser.  If you use Firefox, try Chrome - does the problem still happen?

Hi Rob,

I'm using Chrome and IE. Still no results..

Ok, if it's happening in Firefox, Chrome, IE and Edge then it's most likely an application issue. I think your best bet is to raise a support ticket.  It might be worth pointing them to this question so they can see it's not an isolated issue.

I had the same problem and had to open a request to have Atlassian disable beta features on my account/our instance.

It is account related. Different users on the same browser will see different behavior. I had flipped the beta toggle about a month ago and I was the only one having the problem.

The collaborative editing feature that was the big announcement for Confluence 6 seems to be the issue that was preventing us from doing any editing on any spaces.   We disabled that feature under Administration > Collaborative Editing by turning if off.  Everything is now fine.  In reading documentation on the feature, there is a port that needs to be open for this to work.  Great feature, but too much work it appears to actual get it to work.  Interested to hear of anyone running in-house that might have this issue resolved so that we could leverage this feature easily without having to edited ports or change server configurations.

Well, it's disappointing that I'm having the same problem 9 months later (in August 2017). Is there still no solution?

Oops, the problem was my fault. I wasn't editing / publishing correctly.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

488 views 19 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you