Broken links due to baseurl after confluence migration

Hi all,

I tried the steps below however i couldn't get it work.

https://confluence.atlassian.com/display/CONFKB/Some+Attachments+or+Links+Are+No+Longer+Accessible+After+Server+Migration

I have checked the 'BODY' in the BODYCONTENT table has changed with my sql statement for a particular a page but i view it in the Confluence, it does not change.

I am using Confluence 4.2.8, I suspect BODYCONTENT table is not the table that Confluence get content from.

Can anybody please show me some light?

1 answer

I have managed to get it worked :)

Please replace the "href=old_server_name" with "href=new_server_name".

I do not know why the CONTENT body store 'href' instead of the whole wiki mark up.

So just replace wiki mark up link (e.g: [link|text]) and html anchor link (e.g: <a href=link/>)

Thanks.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,046 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you