It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Dear all!

We have freshly installed Confluence 4.1.3 in our company and when I try to "copy / paste" an image from a picture editor or from a screenshot tool I only do see a red rectangle showing "broken image" with FF 10. If I use IE8 I do not even see anything when using right mouse "Paste" or CTRL-V.

As Confluence is advertised with "it just works" I assume that some settings are missing?

Anyone an idea?

thanks,

Christian

18 answers

1 accepted

6 votes
Answer accepted
Joe_Clark Atlassian Team Feb 02, 2012

Hi Christian,

It looks like this feature is not working with the latest Firefox update (FF 10). I've just created a bug report for you here: https://jira.atlassian.com/browse/CONF-24567

You can vote for the issue and/or watch the issue to be notified of its progress.

Thanks Joseph.

Just out of curiosity, are there any plans to reduce those compatibility issues? I mean Firefox is throwing out a major release every few weeks and every time it seems to have a major impact on some core functionalities in Confluence. I will be updating a customer's Confluence instance today, happy that drag&drop of attachments (with FF 7, 8 and 9) is working again since 4.1.3 https://jira.atlassian.com/browse/CONF-23360 and now I have to tell those people (again) not to upgrade their Firefox. Since not every company has a centralized software distribution it's almost impossible to avoid that people randomly update their browsers... Could Atlassian give out some advice on a regular basis on which should be the current "browser of choice"? Thanks anyway.

Cheers Christian

P.S. If I was searching for this bug in JIRA I would probably look in the "Browser Support" Component.

Joe_Clark Atlassian Team Feb 12, 2012

(The bug triager has now added the browser support component :-) )

We're still looking at ways we can improve our current problems with Firefox version incompatibilities. The decision by Mozilla to release new versions so frequently has really been a curve-ball for us (and I imagine for others as well). At this stage, I think the best thing to do would be to add a watch to our Supported Platforms document - http://confluence.atlassian.com/display/DOC/Supported+Platforms which should be kept reasonably well up-to-date.

This bug is clearly back, so please consider editing your answer to make clear that it solved the 2012 issue but not the 2017 issue.

Or you could just read the dates on the post. 

No-one has the time or desire to update old questions - there's millions of them!

StackOverflow answerers do update stale answers sometimes, to help the users. I guess it's not your problem, it's just that this site allows such long comments we don't immediately see the more recent answer with more upvotes, like we would on StackOverflow.

2.5 million people visit the community every month, and several thousand questions are asked every month.  None of us are going to maintain that body of text, you're asking for millions of hours from volunteers.

I've asked the community team if there is a way to stop comments on posts over a few months old.

Just look at the date on the post.  It's not that hard to do.

Still happens even now Feb 2017, and in Chrome you can't even paste an image any more.  Version 56.0.2924.87 (64-bit)

Having the same issue as described by Seth anyone know how to resolve it?

Like Scott_Smith likes this

Same to me. Chrome can't even paste from memory and both safari and safari technology preview show the broken image error after publishing the page. The workaround to first save every item before uploading it is extremely slow. Please get this issue fixed Atlassian.

Like # people like this

Still same issue here for IE 11 and also Chrome 59.0.3071.115 (64-bit)

Just updated to 59.0.3071.115... same Issue

I'm getting the same symptoms as Arthur Vogel reported in March. I'm using Safari Version 11.0 (13604.1.31.2) on macOS High Sierra

Lack of this core functionality to copy/paste images creates very bad customer experience of using Confluence as a product on a daily basis.

Uploading images one by one is not acceptable in 2018.

Atlassian, please fix this issue which was reported and is dated back to 2012.

 

Thank you!

Like # people like this

I don't understand why this question has an "accepted answer". I tried Edge, Chrome, and Firefox and couldn't copy and paste images.

Like Noumenon72 likes this

Because the bug report answered the question, six years ago.

I am facing the same issue. Why just it can't take a copy-paste image. It's highly irritating to post each and every image using the upload option. 

Like Noumenon72 likes this

Not working as of July 2019. Seriously... 7 years to fix a bug for copying and pasting images?!

The problem is not fixed: As of May 2019 I have this problem too (see attachment). I have added svg images into a table.The weird thing:

As soon as I switch to edit mode I can see the images (svg graphics) again. I also can see the images in the Confluence app on m iPhone (assuming they are not in cache).

The problem persists even on re-uploading/re-inserting the images.

This error occurs at least in Safari Version 12.1 (14607.1.40.1.4) on Mac

Regards

brokenimage.png

have it with chrome  50.0.2661.94 m

We use FF25 and it doesn't work there as well.
Same problem with IE8.

When will this topic be solved?

Joe_Clark Atlassian Team Feb 12, 2014

Hi Jan. As you can see in the linked JIRA issue (https://jira.atlassian.com/browse/CONF-29799) it was fixed in Confluence 5.2.4.

If you are still experiencing this problem you can create a new bug report on jira.atlassian.com

I still having issues loading images to a page. The image is visible until i hit publish then the image links get broken. The third time i tried uploading the images it worked. Tried both to drag and drop and browse computer.

Using Chrome:
Version 78.0.3904.70 (Official Build) (64-bit)

Firefox 70.0.01 same thing

Like Noumenon72 likes this

Also having this issue. I copy and pasted a note from Onenote, and email, and some other things and they all show up fine in the edit but once I preview or publish they break. Latest version of Chrome. Version 78.0.3904.97 (Official Build) (64-bit)

1 vote
Mandaaar I'm New Here Jan 16, 2020

Hellooo - I was having this "Broken Image" issue with a .JPEG file that I had saved.

I had a funny character in the file name (In my case it was "&"), once I removed this the image loaded with no issue.

Might be worth double checking if your image has any strange issues.

(... experiencing same issue in Firefox now, June 2013)

Experiencing same issue in Firefox, July 2013.

Oddly enough, this feature was working on Friday, now it's Tuesday and Firefox must have updated over the weekend... still working perfectly in Chrome and totally non-functional in IE8.

Same issue here as well. If I copy and paste the image in Chrome and save, the image displays in IE and Firefox fine but copying and pasting an image in firefox causes it to display 'broken image' instead.

0 votes
Joe_Clark Atlassian Team Jul 09, 2013

To those of you who are re-experiencing this problem with recent versions of Firefox (Firefox 22.x), the bug report for this problem is here: https://jira.atlassian.com/browse/CONF-29799

Only way around this is cludgey... Save your image as a jpg, then upload image into Confluence. Direct paste from memory, which wroked in the past, now fails in all browsers...

Broken for me in Chrome 72 and copy/pasting data-uri images

I think it depends on how the clipboard represents the data.  I had an image in Powerpoint that I copied and pasted, and it didn't work.  Then I used the window Snipping Tool, and when I pasted, a progress bar appeared, and it worked fine.

It also doesn't work if you try and drag and drop a .png from preview into the upload field. If you select the same .png from the file browser then it works. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

327 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you