It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Assistive skip links format error

On Confluence 6.15.4

Based on the 404 reports from our pages it looks like the assitive skip link to #title-heading is broken.

The folllowing set of links are defined for each page, and the first #title-heading is malformed due to the leading "\" on some pages. This is impacting SEO.

There seems to be no way to disable this feature or a manual override that fixes it.

<ul id="assistive-skip-links" class="assistive">
	<li><a href="\#title-heading">Skip to content</a></li>
	<li><a href="#breadcrumbs">Skip to breadcrumbs</a></li>
	<li><a href="#header-menu-bar">Skip to header menu</a></li>
	<li><a href="#navigation">Skip to action menu</a></li>
	<li><a href="#quick-search-query">Skip to quick search</a></li>
</ul>  

 

2 answers

1 accepted

0 votes
Answer accepted

Following change is a workaround for this issue:

org.apache.tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true

This will allow the slash in that broken element to be correctly interpreted.

0 votes

Hello Ingmar,

Thank you for contacting us about this.

I've found that there's an existing bug due to the skip links not working properly:

This has been included in this other request to get Confluence up to 508 Compliance. The developers will document their progress on this thread:

There is not currently a workaround, but please keep an eye on those threads as well as this Community post; if anyone has a solution that has worked for them, it will be added there.

Regards,

Shannon

@Shannon_Spaniol  the issue you linked is related but not identical to what I am reporting here. The problem I see is that there is a malformed hidden link. Notice the \ prior to #

I was unable to find any bugreports on the matter.

<li><a href="\#title-heading">Skip to content</a></li>

Ingmar,

In general, the ticket was about broken skip links. Any issues regarding broken skip links are related to section 508 compliance, which will be addressed in that 2nd bug ticket (CONFSERVER-12383).

I hope that's clear, but let me know if you have any questions.

Regards,

Shannon

Following change is a workaround for this issue:

org.apache.tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true

This will allow the slash in that broken element to be correctly interpreted.

@Shannon_Spaniol  can this be included in the next release if no fix for the root cause is included?

Ingmar,

Thank you for sharing that workaround. I've included it in the bug ticket I raised in an internal comment to Atlassian staff in order to suggest it as a workaround. 

I am not in the development team myself, so I can't say for sure if the team will include it in the next release, but I've forwarded that on so they can consider it when working on a fix for this bug.

Thank you again, and take care.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

109 views 3 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you