After upgrading from 6.07 to 6.3.2, confluence doesn't load properly

I performed an upgrade to confluence on Linux to 6.3 from 6.07.  After the upgrade, the reverse-proxy seems broken.  The /confluence part of the url is missing from all links.

 

Any help would be appreciated!

3 answers

2 accepted

3 votes
Answer accepted

The upgrade has probably stripped it from your <install>/conf/server.xml

There should be a line like

<Context path="/confluence" docBase="../confluence"

I expect you'll find the path is missing

Ann Worley Atlassian Team Aug 03, 2017

Oops, I posted while you were already on it. Sorry, Nic.

0 votes
Answer accepted
Ann Worley Atlassian Team Aug 03, 2017

Maybe the context path "/confluence" was not migrated over during the upgrade. Please see How to change the Confluence context path as that guide explains where the server.xml is and what to edit.

You guys are quick!  That was the problem.  Thanks!!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,034 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you