Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't delete space after changing username

Hello,

I created a space to test Confluence out, afterwards I changed my username and since then, I lost administrator rights to that space. I am the organization admin and thus should be able to delete it, but I can't. I checked under the space settings which groups or user were listed under "administrators" and it lists the following: "Confluence Analytics (System), Former user, Chat Notifications".

Now, I don't have a clue how the space should be deleted, can anyone help?

1 answer

0 votes

Hello!

Thanks for reaching out for your space permissions with Cloud free. Cloud free does not have permissions at the space level, thus why you’re not able to add yourself back in. With Cloud free, all spaces are open to all of your active users within your site.

For deleting a space, you should be able to navigate to the Space through the following steps:

  • Navigate to the Space via the Space View
    • image.png
  • Select Space Settings
    • image.png
  • Select Overview > Delete Space
  • Proceed with deleting the Space.

Further information on the Cloud free (including permissions) may be found at Permissions and restrictions in the Free plan.

I hope this proves helpful and you’re able to remove your space.

Regards,
Stephen Sifers

Hello Stephen,

That's the entire problem, I as organization admin, can't delete my Space from the Space Settings. Look at the screenshot below: d9da9d4813ed54eabb29cd51731a5740.png

Like Stephen Sifers likes this

Hello again!

Thanks for confirming you’re not able to remove the space. We’re able to recreate the issue on our end for sites imported from a server product with permissions applied to said space. With this said, you’ll need to access your admin portal and add your account to the confluence-administrators group. 

Please follow these steps:

  1. Navigate to https://admin.atlassian.com
  2. Select Manage users for your site
  3. Select the user you wish to modify the permissions for and select “Add user to groups”
  4. Locate the “confluence-administrators” group and select it and click “add to groups”
  5. Once done, attempt to clear the permissions on the space OR delete the space.

I hope this proves helpful in deleting your space.

Regards,
Stephen SIfers

Hello Stephen

It seems that the "confluence-administrators" group isn't present for some reason as you can see in the screenshots below...

Screenshot 2019-10-16 at 00.03.22.pngScreenshot 2019-10-16 at 00.03.49.png

My account is part of the "site-admins" group and I am still not able to delete the Space. Same result as my screenshot in my previous post.

Kind regards

Appstruct

Like Stephen Sifers likes this

Hello,

Thanks for including screenshots and further information around your groups. Since your account is a site-admin you’ll be able to manage the site and users/groups. With this said, could you please check to ensure your account (or your admin account) is added to the Administrators group?

This should allow you to be an admin again within the Confluence application and allow you to delete the space in question.

Regards,
Stephen Sifers

Hello Stephen

Like you've asked, I added the same account to the "administrators" group, but I'm still not able to delete this particular space. As you can confirm on the screenshots below, I am indeed added to the "administrators" group and got admin access to Confluence as specified by the group. I can delete another space of mine perfectly, but this particular one is still bugged it seems... I've no clue on what to do anymore.

Screenshot 2019-10-18 at 10.25.42.pngScreenshot 2019-10-18 at 10.33.03.pngScreenshot 2019-10-18 at 10.33.16.png

Kind regards
Appstruct

Hello again,

If we’ve confirmed the users within the administrators' group and you’re still unable to remove the space then we’ll need to revoke any import permissions within the space to allow for this action. Here are the steps for this:

Open up a space to all users

After you switch to the Free plan, any permissions you’ve set on a space will remain in place. If needed, you can open up the space to all users. This will let anyone with access to your Confluence site view the space, add pages to it, and more.

You won’t be able to undo this action. If you need to reset the space permissions, you’ll have to go back to one of our paid plans.
  1. Click the space’s name in the sidebar.
  2. Click Space settings > Permissions.
  3. In the Upgrade for space permissions box, click Grant all users permissions for this space.
  4. Click Grant permissions.

Source documentation: Permissions and restrictions in the Free plan

The above should remove any permission scheme which is preventing our confirmed users from being able to delete the space. If we’re still having issues past this then it will warrant the creation of a support case for further investigation.

Regards,
Stephen Sifers

Hello Stephen

Once again thanks for helping me out here. Sadly enough, the permissions tab on that particular space isn't available either as you can see on the screenshot below:

Screenshot 2019-10-22 at 09.59.36.png

It is visible under the space settings of other spaces though (check screenshot below from another space), thus it seems that the above space is really bugged out.

Screenshot 2019-10-22 at 09.59.49.png

Hello,

We’ve confirmed on our end that this is part of a bug with the Cloud free. We’re working with the team to help find the root cause of the issue. Once we have a bug for the issue we’ll link it back here to help others reference the issue as well.

Sorry for the inconvenience this has and will cause and we thank you for your patience while we work through this issue.

Regards,
Stephen SIfers

Hello Stephen

Thanks for the update, would love to hear something back from you when you know more.

Kind regards
Appstruct

Like Stephen Sifers likes this

Hello,

Just following up, we’ve created the bug for this issue. You may find the bug request for this issue at CONFCLOUD-68319. Please vote and watch this request for future updates.

Thanks again for reporting this issue.

Regards,
Stephen Sifers

Like Fidel likes this

The ticket is closed but the bug has not been fixed. No way to delete a space even on paid subscription 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Security Advisory for Jira Service Management

On October 20, 2021, Atlassian published a security advisory for Jira Service Management. The full advisory is available at this link.  We've seen a number of questions already asking for...

72 views 0 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you