fullStatementInfo.getHitCount() api returns zero always for lines which are covered by unit tests.

Hi ,

fullStatementInfo.getHitCount() api returns zero even though line was hitted by unit test which i can see from HTML report generated on same clover DB ,May i know the reason why its showing zero through api ?

Simmilar scenario i tried with clover DB which is generated by running functional test case and fullStatementInfo.getHitCount() is showing correct results for that. Its just not showing for lines which are hitted by Unit tests.

Thanks,

Gaurav

1 answer

0 votes

Hi Gaurav, it's hard to tell why you see a difference without seeing a test case and data. 

In case you have an active Clover maintenance subscription, feel free to create a ticket on getsupport.atlassian.com. 

In case you are using an open-source version of Clover, please try to create code sample (as small as possible) and attach it to your question, so we could reproduce it.

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

262 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot